7 Replies Latest reply on Aug 4, 2016 1:09 AM by cgoffroadinc

    Fallout 4 Crossfire - Still Performing Extremely Poorly

    salamand3r

      I do appreciate that fact that you finally released a Crossfire profile for Fallout 4, I really do.

       

      However, my question is, why?  Is it just to tick a check box?

       

      Currently, for myself and a lot of others (in fact, I daresay everyone I have contact with that has a Crossfire setup), the performance scaling is negative - like, really negative.  On the order of a 50% plus reduction in FPS in some areas, and no less than 10% in general.  Note that all of these instances are on Hawaii GPUs - I don't know if effects other GPUs.

       

      So my question is - is there some setting in the game that is messing with this? I've tried virtually every combination of settings to help the poor Crossfire profile out, but Fallout 4 on minimal settings at 1080p still runs worse on my R9 290s with CFX enabled than it does on a single 290 at 1440p with everything set to max.  At 1440p, the 290 (and yes, it is overclocked, 1220mHz core/1550mHz VRAM) can hold 60FPS virtually everywhere aside from in the dreaded city areas - I see drops to the low 40s there.  In CFX, with the aforementioned minimal settings, I see a max of the mid 50s, with drops into the teens or 20s in city areas.

       

      I'm not the only one having this problem.  We've had several driver updates now - and we still do see some flickering in some areas, an issue which has now been dropped from the "Known Issues" l

       

      So what gives? Do I need to do an .ini tweak somewhere? Is there something that needs to be changed from the default setting in Crimson?  Seriously - I don't believe you guys can have dropped the ball that badly, or care that much about a (frankly meaningless, and completely un-trumpeted) marketing check box that this could be intentional.

       

      Does anyone have good CFX performance?

        • Re: Fallout 4 Crossfire - Still Performing Extremely Poorly
          amdmatt

          Unfortunately the game is not very friendly towards Multi GPU and this has a negative effect on CrossFire scaling and performance. Parts of the game, such as the City are quite heavy on the CPU which can result in a drop in GPU usage and CrossFire scaling.

          2 of 3 people found this helpful
            • Re: Fallout 4 Crossfire - Still Performing Extremely Poorly
              salamand3r

              Thank you - that is basically what I thought, but since all "known issues" concerning FO4 have been dropped off the patch notes, you can understand why I thought that there might be some magic bullet setting that just was never mentioned.

               

              I would like to add though, I don't see any direct correlation between CPU usage and FPS drops - aside from the fact that I am running a 3960x at 5.0gHz (validation CPU-Z VALIDATOR ) which should be able to handle basically anything, I have never seen over 20% load on a single core at any point in FO4.  The blame probably lies squarely with poorly optimized code in FO4 itself at this point.

               

              Thank you for the response, but I would also like to repeat my question - if Crossfire is going to continue to provide negative scaling, what is the point of the profile?

              1 of 1 people found this helpful
            • Re: Fallout 4 Crossfire - Still Performing Extremely Poorly
              fragment

              Hi,

              salamand3r & amdmatt

               

              First my specs:

              I have a Sapphire R9 270X 2GB Crossfire setup on a MSI Z97 Gaming 5 with a i7 4790K @4.5 Ghz and 16 GB RAM (1066Mhz)

               

              I run Fallout 4 with the 16.3.1 drivers at the moment and I get stable 60 FPS in 1440p part from those framedrops down to ~40FPS sometimes. But its not a persistent drop down to 40, it seems mostly to happen in dense areas when stuff is being calculated because you enter a new grid. After textures and everything is loaded (1-2 seconds) it is back to 60FPS even in cities (I checked this in Lexington for example and with the Corvega Plant).


              When my GoPro is back from repair I will upload a video to show my performance.


              I can just say, yes Crossfire is a little bit of a hassle sometimes.

              BUT! Of all 100% of games, maybe 50% dont work right away with Crossfire out of the box.

              But 99% of those 50% can be get working with proper configuration.

              And I have to add i fizzled around 2 days for Fallout 4 to work as best as it can. But it was worth it!

               

              My general hints for AMD cards are. (not in a specific order.. although some settings are FAR MORE important than others to achieve high stable FPS)

               

              a. set tessellation to OFF in Fallout 4 Radeon Profile

              b. set AMD CrossFire Mode to "Fallout 4" Profile of course

              c. close ALL... and i mean ALL... other programs apart from Fallout 4

              d. DO NOT change CPU Priority of the process (it is not needed as long as you comply with c.)

              e. FO4 Launcher settings are:

              ---------------------------------

              1440p

              TAA enabled

              16x Anisotropic

              Texture Quality Ultra (if your VRAM = 2GB you want to set it to Medium)

              Shadow Quality Ultra (if your VRAM = 2GB you want to set it to Medium)

              Shadow Distance Medium (IMPORTANT !!!)

              Decal Quality High

              Lighting Quality Medium (IMPORTANT but will be adjusted later additionally)

              Godrays Quality Low (IMPORTANT !!!)

              Depth of Field Standard(Low)

              Ambient Occlusion Off

              Screen Space Reflections Off

              Wetness Off

              Rain Occlusion Off

              Motion Blur Off

              Lens Flare Off

              Object Fade Max

              Actor Fade Max

              Grass Fade Max

              Item Fade Max

              Distant Object Detail Ultra

              Object Detail Fade Ultra

              -----------------------------------

              So now dont get irritated about the fade and distance settings, they dont affect performance much as long as you have the settings above exactly as I told you.

              f. In addition to the settings you made in the launcher (which you do FIRST, then you CLOSE the launcher, and then you NEVER EVER start the launcher again, instead you use Fallout4.exe to start the game) you will now edit your

              Fallout4.ini and Fallout4Prefs.ini (this overwrites some settings in the launcher by disabling some NVIDIA Gameworks settings COMPLETELY which is needed to make the game run SMOOTH)

              - Fallout4.ini (add or change to in the designated columns):

              [General]

              iNumHWThreads=8 (you can put this on 8 even if you have less cores)

              bUseThreadedBlood=1 (new entry)

              bUseThreadedMorpher=1 (new entry)

              bUseThreadedTempEffects=1 (new entry)

              bUseThreadedParticleSystem=1 (new entry)

              bUseThreadedAI=1 (new entry)

              bUseMultiThreadedFaceGen=1 (new entry)

              bUseMultiThreadedTrees=1 (new entry)

              bForceUpdateDiffuseOnly=0 (new entry, if your VRAM = 2GB you add this)

              iTextureUpgradeDistance1=1000  (new entry, if your VRAM = 2GB you add this)

              iTextureUpgradeDistance0=500 (new entry, if your VRAM = 2GB you add this)

              iTextureDegradeDistance1=1100 (new entry, if your VRAM = 2GB you add this)

              iTextureDegradeDistance0=600 (new entry, if your VRAM = 2GB you add this)

              [Display]

              iPresentInterval=0 (IMPORTANT !!!)

              bNvGodraysEnable=0 (IMPORTANT !!!)

              [ImageSpace]

              bDoRadialBlur=0

               

              - Fallout4Prefs.ini (add or change to in the designated columns):

              [Display]

              bVolumetricLightingEnable=0 (very IMPORTANT, thanks to nvidia)

              iVolumetricLightingQuality=0

              bForceIgnoreSmoothness=1 (new entry)

              iPresentInterval=0

              bFull Screen=1 (0 if you have multiple monitors, but its best to run on single monitor, use WIN+P to switch fast before launching game)

              bBorderless=1

              bVolumetricLightingForceCasters=0

              iTiledLightingMinLights=0

              bComputeShaderDeferredTiledLighting=0

              [LightingShader]

              bScreenSpaceReflections=0

              bScreenSpaceSubsurfaceScattering=0

              [Imagespace]

              bMBEnable=0

              bLensFlare=0

              bDoDepthOfField=0

              bScreenSpaceBokeh=0

              [BlurShaderHDR]

              bDoHighDynamicRange=0

              [BlurShader]

              bUseBlurShader=0

              [General]

              iNumHWThreads=8

              [Water]

              bUseWaterDisplacements=0

              bUseWaterRefractions=0

              bUseWaterReflections=0

              bUseWaterDepth=0

              [NVHBAO] (get it?... its proprietary tech that slows your amd card down, DISABLE)

              bBackgroundAOEnable=0

              bDepthThresholdEnable=0

              iDepthClampModeEnum=0

              bBlurEnable=0

              bEnable=0

              [NVFlex] (same here, DISABLE)

              iQuality=0

              bNVFlexEnable=0

              bNVFlexInstanceDebris=0

              bNVFlexDrawDebris=0

               

              g. so now you have saved those configs and backed them up as well because if you should accidentally run the launcher, it will all be overwritten !!! (the most crazy part is, all nvidia gameworks options are REENABLED then... its a conspiracy)

              h. the last and most important thing now is, I LIED at c. you really want to have all programs closed when running Fallout 4 EXCEPT you want a framerate limiter because by setting "iPresentInterval=0" we removed the games internal one. but we want that for better performance.

              - AMD Catalyst frame limiter is not working!

              - use STANDALONE RTSS or BANDICAM (shareware/trial) for that

              - DONT use rtss with afterburner together for that! every sensor you query & display is sucking up performance

              - for RTSS use Application detection level: Low, Stealth mode: OFF, Custom Direct3D support: OFF, Framerate limit: 60FPS, OSD RENDERING MODE: RASTER 3D (!!!)

               

              This is the best you can do. I will soon make some youtube videos of improving performance on AMD crossfire and older AMD cards in general because many people just don't know that they can improve their gaming performance with some little tweaks.

               

              PS: For trolls saying the game will look like ... with all those settings disabled. It's wrong! Try it, or be quiet. Game looks super crisp in 1440p with TAA all day

              1 of 1 people found this helpful
                • Re: Fallout 4 Crossfire - Still Performing Extremely Poorly
                  rustys51

                  Was having massive frame drops and can confirm that after applying the settings above from fragment I'm getting solid 60fps, also visual quality is fine.

                  • Re: Fallout 4 Crossfire - Still Performing Extremely Poorly
                    cgoffroadinc

                        Hey Fragment dose setting bBorderless=1 turn on boderless window mode? and if so wouldn't that in turn turn off crossfire?

                    i myself haven't been able to get crossfire to work better then with just one card unforgettably for me when in crossfire i get massive spikes and lag and random down clocking. and voltage? I've tried turned off all power saving ULPS and stuff and the 30 fps cap. to me it just seems poorly optimized for crossfire. hopefully well get a better profile!

                          anyone can think of anything i might of missed i'm always open for suggestions! ill post my specs below.

                    Sorry if this reply isn't correct first post and i'm not a normally a forum poster so i apologize in advance.

                     

                    Specs, sapphire 390 nitro x 2,  8350 black 4.7 Ghz "Water Cooled"   Mobo. Asus Crossfire v Formula-Z.   16 Gb clocked "2133" g.skill rip jaws 

                    2 850 Evo 500Gb SSD's    Crimson 16.7.3 driver and Win 10. Pro 64 bit.