8 Replies Latest reply on May 6, 2016 12:23 PM by mode

    A10-7850k and R7 250 but no crossfire option

    paged.csci

      Hi Community,

       

      I'm running Windows 10 with an A10-7850k and an MSI R7 250 with 2GB of DDR3 memory, and all indications is that they should work together. I've tried the most modern driverset, as well as 15.7 and 15.11, but I can't seem to get it to show up.

       

      When I try with 15.7, I run into the problem that it says that Windows doesn't support the current driver, and runs the R7 250 as an M360 instead for some reason (which doesn't make much sense to me) but it won't let me change the driver time to an r7 250.

       

      When I try 15.11, it seems to work fine, except there is no Crossfire option to turn on.

       

      When I try 16.2 it also seems to work fine, but with no Crossfire option. I read somewhere that Dual Graphics hasn't been added to the new Crimson drivers.

       

      Any ideas of what might be going on or how I can fix this?

       

      Cheers

        • Re: A10-7850k and R7 250 but no crossfire option
          black_zion

          The best fix would be to return the 250, buy a 260 for all of $15 more, and disable the APUs graphics. You'd have stronger graphics than the 7870+250 could ever give without any of the drawbacks of Crossfire.

          • Re: A10-7850k and R7 250 but no crossfire option
            amdmatt

            Please provide more information about your system. For example, what Motherboard are you using? There should be an option you have to enable in the bios to support Dual Graphics.

            • Re: A10-7850k and R7 250 but no crossfire option
              teruksor

              I have a similar system, with Gigabyte Sniper and an XFX R7 250 card. And I could enable Crossfire without problem. Here is what I did:

               

              - Make sure you have all drivers completely uninstalled, there is a clean uninstall software you can download here.-

              - With only the APU connected, remove the GPU, turn on the computer and install the latest driver, I used the Crimson 16.2 hotfix but also worked with the 15.12.

              - Reboot make sure the driver is working well, then turn off the computer and install the GPU.

              - Go to the bios and in Peripherals -> GFX  Configuration make sure the Primary Video Device is set to IGD (sometimes it changes automatically when you install the GPU to the North Bridge) set Integrated Graphics to Force and UMA buffer to Auto. (I'm assuming the bios is similar in both cards since both are Gugabyte)

              - Make sure the screen is plugged to the motherboard and not the GPU and reboot.

              - Once in Windows open Radeon Configuration and on the Display tab on the top right corner click "Additional settings" and the old Catalyst window will open there in Performance you should be able to see the option to enable or disable Dual graphics.

              1 of 1 people found this helpful
              • Re: A10-7850k and R7 250 but no crossfire option
                demo

                Hi...

                Does this answer work?

                I have a similar question, here: How to setup dual graphics amd a8 7600 + r7 240 ?  [Solved]

                 

                teruksor wrote:

                I have a similar system, with Gigabyte Sniper and an XFX R7 250 card. And I could enable Crossfire without problem. Here is what I did:

                - Make sure you have all drivers completely uninstalled, there is a clean uninstall software you can download here.-

                - With only the APU connected, remove the GPU, turn on the computer and install the latest driver, I used the Crimson 16.2 hotfix but also worked with the 15.12.

                - Reboot make sure the driver is working well, then turn off the computer and install the GPU.

                - Go to the bios and in Peripherals -> GFX Configuration make sure the Primary Video Device is set to IGD (sometimes it changes automatically when you install the GPU to the North Bridge) set Integrated Graphics to Force and UMA buffer to Auto. (I'm assuming the bios is similar in both cards since both are Gugabyte)

                - Make sure the screen is plugged to the motherboard and not the GPU and reboot.

                - Once in Windows open Radeon Configuration and on the Display tab on the top right corner click "Additional settings" and the old Catalyst window will open there in Performance you should be able to see the option to enable or disable Dual graphics.