57 Replies Latest reply on Mar 23, 2016 7:09 AM by vaporx

    Sapphire not responding to my RMA after 4 months!!

    fahx

      Soooo, i have a Sapphire R9 280x Toxic, and i have an issue with frame drops, lock ups etc. i USED to have a 750ti that worked well, ran League @ 135+ fps (not the best i know) with the toxic im getting an fps anywhere between 17-58. same gfx setting, etc. i have a Corsair AX850 850w psu - plenty of power and a AMD FX 9590 CPU - more than enough for it to be bottlenecking it.

      Anyway - i have been messageing Sapphire via the correct channels since early Dec 2015 and havnt heard anything at all back from them. i have logged a RMA and it has had no response, at all - Please see image... (all the entries are from me)

      http://imgur.com/wimmWlf

      What can i do? the retailer tells me to contact sapphire and they will not help any further....

        • Re: Sapphire not responding to my RMA after 4 months!!
          amdmatt

          We can help you to troubleshoot the issue and hopefully resolve it, but we cannot help with an rma.

           

          Please provide more information and we will try to help.

            • Re: Sapphire not responding to my RMA after 4 months!!
              fahx

              I have tried every single piece of troubleshooting for this card i can find.

               

              So, i get a huge frame drop - e.g League Of Legends runs between 17-58 fps, my old 750ti ran it at 100-185fps. cinebench, heaven and firestrike benchmarks give a massivly reduced score im compassion to my old 750ti (which was only 2gb, this card is 3gb). some games make the AMD Catalyst display driver stop working all together - games such as CS:GO. im not tring to run these games on stupid settings either - they are being ran on moderate.

               

              The GPU never exceeds 20% of usage but is always at 100% power use.

               

              my specs are -

               

              AMD FX 9590

              8gb Corsair Ram

              850w Corsair PSU

              ASUS 970/PROGAMER Aura

              Latest catalyst drivers - and even tried past drivers

              Windows 10 64bit