0 Replies Latest reply on Mar 6, 2016 10:57 AM by rlfawcett

    Really bad FPS performance with AMD Radeon HD 6900 Series

    rlfawcett

      Basic outline of issue.

      My computer used to run games on ultra with no issues, after an update a while back I got an AMD Radeon Settings programme in my control panel (Think this is when Crimson came out) and my computer really struggles with games now. Example being my World of Warcraft which used to run on Ultra 50-60fps fine, now barely handles "Good" or "Fair" above 30fps. On Ultra it's jumpy and stays on around 18fps while idle, dropping even lower when I do something in game.

       

      My Computer specs from DxDiag
      Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601)
      System Manufacturer : System Manufacturer (This bits weird I know, possibly because it was built custom by Arbico PC's)
      BIOS: BIOS Date: 09/20/11 15:50:36 Ver: 06.01
      Processor: AMD FX(tm)-6100 Six-Core Processor
      Memory: 16384 RAM
      DirectX Version: DirectX 11

      Graphics Chipset: AMD Radeon HD 6900 Series

       

      When I go into my AMD Radeon Settings and click updates, it says my Software is up to date with currently installed 15.30.1025.1001-151129a-297019E

      When I click System>Overview it tells me Radeon Software Version 15.11.1 Radeon Software Edition : Crimson

      AMD Radeon Settings 1.png

      AMD Radeon Settings 2.png

      AMD Radeon Settings 3.png

      What I have done

      I've tried going on AMD driver downloads and downloading all the most recent ones there (15.12) and it didn't change anything, not even the Radeon Software Version in the Radeon settings, so maybe if that's the issue and I did it wrong somehow?

       

      I have also been told going back to the drivers before Crimson might work, but I don't want to just jump into uninstalling graphics drivers and potentially breaking it all without a proper suggestion directly to me that I should do this.

       

      I'd really appreciate feedback on why my fps seems to be so low with these specs. Identifying the issue.

      Is there anything I can try? Or might it be a possibility my graphics card is simply fried and broken somehow?

       

      Other notes
      I've downloaded and tried using the autodetect programme for drivers (It just tells me i'm up to date.

      I'm not running multiple programmes while gaming, the problem persists even if I just have the game open like World of Warcraft on its own.

      I've looked all over forums and not found any solution that reliably works