2 Replies Latest reply on Mar 3, 2016 1:45 AM by kindred

    Windows 10 64x Support For Crossfire R9 390x

    kindred

      So I've run into an issue regarding crossfire and after extensive searches it has come to my attention that I am the only one with the issue.

      -

      I've recently purchased a new MSI R9 390x to pair with my other MSI R9 390x. I am aware of the power draw and a have decent enough power supply to run it.

      So, my issue is that when I installed them both, I received no errors no BSOD's nothing. It goes through post and just sits there at the windows logo with the spinning dots. after about an hour and a half it will BSOD and rerun through the booting process. I have tried to fix this multiple times by uninstalling the drivers with DDU and reinstalling them. Still Nada. Fresh installs of windows. Nada, Same thing. I have switched the card around. They work fine individually and they work fine in both PCI slots.

       

      BUT. By sheer mistake I accidentally installed a windows 10 32bit OS and to my surprise booted first time no hassle. I could run crossfire and everything. Installed drivers just fine and rebooted just fine. So thinking maybe it was a fluke, I redownloaded then reinstalled windows 10 64bit and guess what. STILL STUCK AT WINDOWS LOGO! So I reinstalled 32bit back on there and whala!! It worked like a charm. Sad thing is you cant run most games on a 32 bit system, and you can't have more than 4gb of ram either so its not a very reliable setup.

       

      So in conclusion, anyone got a fix for this? Maybe toss me a bone and tell me whats causing it?

        • Re: Windows 10 64x Support For Crossfire R9 390x
          xeleron

          Please post your system specs.

            • Re: Windows 10 64x Support For Crossfire R9 390x
              kindred

              So I figured it out. The answer was right in front of me the entire time! So when I installed 64 bit windows everything was perfect. With the exception that windows was not booting. Then it struck me. Windows would only boot from 32 bit OS after reading only 3.5 gb of ram. Yea that's right... 64 bit never got to a faulty ramstick that I had in the forth slot. Therefore because 64 bit windows would read it, it would cause a threadpool error. Windows 32bit would pass right by it. I must have shocked it somehow (IDK HOW THO!!?) Thank you xeleron for bumping my head when you asked me about my specs. It made me think of the ram. I owe everything to you.

              P.S.

              Processor- i7-4790k

              Asus z97-a Mobo

              Dual MSI R9-390x Crossfire

              240 Kingston SSDx2

              2TB Seagate 7200rpm

              1000 Cougar Power Supply

              32GB Kingston ram now 16gb till I can get a new ram sticks.

              Phantom 410 Case Red/Black