10 Replies Latest reply on Aug 27, 2016 10:59 PM by andrecirillo

    Asus Radeon R9 390 not reaching full clock speeds in some games

    chuckwolf@gmail.com

      While trying out my brand new Asus R9 390 with Star Trek Online I was getting extremely low frame rates while in ground content, lower even than with the R9 380 that this new card replaced.

       

      By low I mean sub-15 fps even with all graphical settings turned down, yes it's at 1440p but that should be the least of the issues.

       

      While playing in windowed mode with GPU-Z running to monitor GPU core clock speeds. I noticed that while on ground the GPU core speed never went above 400 mhz. Bear in mind the 3D clocks of this GPU are 1050 Mhz normally.

       

      Unlike some others it hasn't crashed, just the clocks running at low speeds, like it reuses to go into 3d mode.

       

      I've tried this using both DX11 and DX9 modes, with both Crimson drivers, most recent hotfix ones, and even the last known Catalyst.

       

      My system Specs for those wondering:

       

      AMD fX-8320

      Asus Radeon R9 390 Strix 8gb OC

      16 GB Kingston Hyper-x PC-1600

      Samsung 840 EVO 500 GB SSD

      Asus PB258Q 25" 2560X1440 monitor

      Windows 10 Home 64 bit

        • Re: Asus Radeon R9 390 not reaching full clock speeds in some games
          xeleron

          Try running something else and see if the GPU rises the clockspeeds.If it does,we have an issue with the game,if it doesn't,we have an issue with the GPU.Try running a simple 3dmark benchmark or a furmark gpu bench (ignore the stuttering of the fluffy doughnut,this is normal),and see via OSD or via GPU-Z if the GPU rises the performance level.Also,before trying this,make sure all power connectors have been properly placed.

          • Re: Asus Radeon R9 390 not reaching full clock speeds in some games
            amdmatt

            This is a known issue, we hope to have a fix soon.

             

            Known Issue: Core clocks may not maintain sustained clock speeds resulting in choppy performance and or screen corruption

             

            As a temporary workaround, you may try using either Catalyst 15.11.1 Beta or Catalyst 15.7.1 WHQL.

              • Re: Asus Radeon R9 390 not reaching full clock speeds in some games
                chuckwolf@gmail.com

                Tried rolling back to the 15.7.1 Catalyst. after using the clean removal tool.

                As far as performance goes gameplay isn't choppy in the particular game even at low frame rates.

                However even with the 15.7.1 drivers clock speeds depend on what area I'm in In space zones GPU ore clock can near full speed... above 900 Mhz and quite acceptable ~75 fps @ 2560x1440 with all graphics options maxed, with v-sync disabled. (Purposefully trying to stress the Card to force highest GPU clock)

                Some ground maps offer lower performance ~600 Mhz core clock and ~30 fps

                On particular ground map in a mission however nets me sub 400 Mhz clock speeds  and ~15 fps.

                 

                I can understand that the framerate might change in different areas depending on what's being rendered, that normal, but the core clock changing in different areas in unacceptable.

                 

                Especially if i'm deliberately trying to stress the clocks.

                • Re: Asus Radeon R9 390 not reaching full clock speeds in some games
                  andrecirillo

                  Hi amdmatt, I have a R9 380 4GB PowerColor and I've wasted the last 2 weeks trying to avoid the black screen crash. I've went through EVERYTHING (and a bit more) suggested here and nothing helped. I've tested all catalyst and crimson versions and each one had a differente behavior and gave me a different error only when gaming.

                   

                  The only thing that resolved 100% this black screen issue was: installing crimson 1.7.3 minimal (as suggested by amd auto detect utility) and using the 755Hhz default clock detected by msi afterburner. I've also used msi afterburn to set a custom fan profile to avoid the card temperature staying at 60º celsius when idle, because amd default fan profile keeps the fan at 20-33% and only increases when the gpu hits 65º (very poor opmization).

                   

                  It's strange because amd R9 380 reference card has a 970MHz clock. The powercolor card has a 980MHz stock clock but the system can't mantain the card stable at this clock. Some tools detect the 980MHz clock but others detect the 755MHz clock as the default clock. You guys did something similar to solve RX 480 issue, lowering the voltage and clock to mantain the card stable and without consuming more power from pci than it should.

                   

                  I've could also trying increasing the clock a bit and/or use other drivers versions but I'm not in the mood to risk it and have the black screen crash again. Everything got worse after installing kaspersky and windows 10 anniversary update and each time I changed the driver or tried someghint different (clockblocker, radeonpro aa injections, clock and voltage changes) more instability and more crashs I had. So I've uninstalled everything and let only the crimson 1.7.3 minimal setup and msi afterburner. I didn't format the pc.

                   

                  The first time I've used this setup (755MHz without crash) I've had only 8GB RAM in my system and I've had a really bad performance (10-15 fps less in average and ruge fps drops) and couldn't play at all but now I have 16GB RAM in dual channel and the card is very stable (mantaining 50-60fps) in ultra settings. I have a pentium G3258 3.2GHz and I don't even need to overclock it (to 4.0-.4.2GHz to have a good performance). Now I'm going to install a ssd to eliminate hd bottlenecks to help more the system maintaina good stability and performance.

                   

                  That's it amdmatt, in my setup (with a msi h81 motherboard and a 650w psu) the PowerColor R9 380 can't keep it's default 980MHz clock

                • Re: Asus Radeon R9 390 not reaching full clock speeds in some games
                  hnffwim

                  I'm currently facing the same issue with the same card as yours but I guess AMD is trying to address the problem.

                   

                  Anyway, I'm supporting AMD in this issue. XD

                   

                  Go go go AMD.