0 Replies Latest reply on Feb 27, 2016 9:35 PM by danielmgessel

    Possible Feature Request: FrameBuffer Configs without Depth

    danielmgessel

      I just picked up a Radeon R9 Nano and installed it in a system with a fresh Ubuntu 15.10 OS install and the latest drivers (AMD Radeon Software Crimson Edition 15.12 Proprietary Linux Graphics Driver) .

       

      I'm using Framebuffer Objects to do linear space rendering (f11_f11_f10), so I only use the default frame buffer for display after performing gamma correction, dither and (eventually) bloom effects. I did the install and my app, which had worked with a competitor's GPU, stopped working! My bug - I assumed I would get a default frame buffer with no depth and therefore depth test state didn't matter. Fixed my bug and everything renders fine, but I'm not using the allocated depth buffer.

       

      I'm using glXChooseFBConfig and my visual attribs are:

       

      GLX_X_RENDERABLE    , True,

      GLX_DRAWABLE_TYPE   , GLX_WINDOW_BIT,

      GLX_RENDER_TYPE     , GLX_RGBA_BIT,

      GLX_X_VISUAL_TYPE   , GLX_TRUE_COLOR,

      GLX_RED_SIZE        , 8,

      GLX_GREEN_SIZE      , 8,

      GLX_BLUE_SIZE       , 8,

      GLX_DOUBLEBUFFER    , True,

      None

       

      I also tried GLX_DEPTH_SIZE, 0, but it didn't seem to change anything.

       

      Maybe the feature is there, and I'm using bad visual attribs? I'm pretty new to Linux/X as well.

       

      Thanks for any suggestions for a fix on my end or info on whether or not this feature could be added.

      Dan