AnsweredAssumed Answered

AMD Graphics Driver Issues

Question asked by jimmyjamthaman on Feb 24, 2016
Latest reply on Mar 10, 2016 by zombie

Havent been able to use my computer for months thanks to AMD issues!!!

 

Lets start from the beginning...

 

1. Get a notification to upgrade to AMD Crimson 16.1. I do the update through windows update (which I later learned was a mistake) and after its installed, I start getting a BSOD with SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (atikmdag.sys).

2. Clean all AMD files off my computer using DDU (in safe mode)

3. I try installing 16.1 in safe mode. Files download, I run the setup utility, but I can't even get started because I get an error window saying "Detection Driver Error. Please Contact AMD for Assistance"

4. Contact AMD for assistance. Get some follow up from amdmatt and he tells me to try older versions of the software. (15.11.1 Beta)

5. Use DDU to uninstall 16.1 (in safe mode) and try to roll back to 15.11.1 Beta (which was working fine before I upgraded to 16.1.) About halfway through installation (not in safe mode), I get a BSOD that says SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (atikmdag.sys). I say this on the thread I previously posted and get no feedback.

6. Try installing 15.11.1 in safe mode. Get error window that says "Failed to load detection driver." Can't install 15.1.1 Beta.

7. Wait a few weeks, research other solutions (nothing has worked)

8. 16.1.1 Hotfix is out. Download files and try to install. Get BSOD with SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (atikmdag.sys)

9. Try to install 16.1.1 hotfix in Safe Mode, try to run installer and get a window with "Detection Driver Error. Please Contact AMD for Assistance"

 

Long story short- I can't install the newest drivers, I can't install any older drivers, I can't install any drivers in safe mode. I need to install these drivers and nothing works. I've been going around in circles and I need help, please!

 

System Info

MB: MSI 970A-G46 Socket AM3+/ AMD 970/ DDR3/ CrossFireX & SLI/ SATA3&USB3.0/ A&GbE/ ATX Motherboard

Processor: AMD FX-6300 Six-Core Vishera Processor 3.5GHz Socket AM3+

GPU: Radeon R9 280 3GB

RAM: G.SKILL Ares Series 2x4GB DDR3

HD; Seagate Barracuda 1TB

Power: Rosewill Arc M550w

OS: Windows 8.1 x64

 

Can ANYONE help me? Is there a fix to this? All I want to do is some gaming on Steam and I haven't been able to play at all in 2016 because of these stupid issues. I can upload minidump files, event logs, anything. PLEASE AMD DO SOMETHING ABOUT THIS!!

Outcomes