5 Replies Latest reply on Apr 26, 2016 5:12 PM by tmorris

    Hello and OpenCL question

    tmorris

      Hi,

      I'm Thomas and I have 7 years experience working with GPU technology in the UK. My current project is using OpenCL to calculate asteroid and comet orbits. I'm also interested in improving my knowledge of OpenGL.

      Does the latest AMD SDK 3.0 support OpenCL1.2 on a HD6670 card? My OS is Ubuntu Linux 15.10.

      Many thanks,

      Thomas

        • Re: Hello and OpenCL question
          petrkalos

          Hi Thomas,

          AMD SDK 3.0 supports up to OpenCL 2.0 but the 6670 supports up to OpenCL 1.2 see here

          So to answer you question yes you can support 1.2 on 6670.

          The only problem is that AMD doesn't officially provide drivers for Ubuntu 15.10.

           

           

          https://en.wikipedia.org/wiki/Radeon_HD_6000_Series

            • Re: Hello and OpenCL question
              tmorris

              Hi Petr,

              Sorry for my delay in replying, unfortunately I'm still having some problems. I installed the latest AMD fglrx 15.302 driver and glxinfo reports OpenGL 4.5 support:

              OpenGL version string: 4.5.13416 Compatibility Profile Context 15.302

              OpenGL shading language version string: 4.40

               

              When I run clinfo, I see no mention of the GPU:

              Number of platforms:                         1
                Platform Profile:                          FULL_PROFILE
                Platform Version:                          OpenCL 2.0 AMD-APP (1912.5)
                Platform Name:                             AMD Accelerated Parallel Processing
                Platform Vendor:                           Advanced Micro Devices, Inc.
                Platform Extensions:                       cl_khr_icd cl_amd_event_callback cl_amd_offline_devices

               

               

                Platform Name:                             AMD Accelerated Parallel Processing
              Number of devices:                           1
                Device Type:                               CL_DEVICE_TYPE_CPU
                Vendor ID:                                 1002h

               

              I tried a helloworld test built with AMDAPPSDK 3.0 which returns CL_DEVICE_NOT_FOUND if I specify CL_DEVICE_TYPE_GPU. I'm using linux kernel 4.2.0 with xorg-server 2:1.17.2-1ubuntu9.1.

              Many thanks,

              Thomas

                • Re: Hello and OpenCL question
                  tmorris

                  Hi,

                  I rolled back to Ubuntu 14.04 (Linux 3.19.0) and followed the procedure in the AMD Catalyst installer notes (using the latest Debian packages). Xorg server version is 1.17.2

                   

                  There are no errors in the X server log (warnings about falling back to old probe method appear benign) and the fgl_glxgears test runs fine.

                   

                  Running 'sudo clinfo' only shows the CPU device. The library /usr/lib/libamdocl64.so exists. If I point the ICD file to the libamdocl12cl64.so library then clGetPlatformIDs returns CL_DEVICE_NOT_FOUND.

                   

                  Any hints please?

                  Many thanks,

                  Thomas

                   

                  PS: I haven't installed the AMD APP SDK, this is just using the Catalyst driver. clinfo is the one in /usr/bin.

                  Snippet from strace in case it's helpful:

                  open("/usr/lib/libamdocl64.so", O_RDONLY|O_CLOEXEC) = 5

                  read(5, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0@\212`\0\0\0\0\0"..., 832) = 832

                  fstat(5, {st_mode=S_IFREG|0644, st_size=64075288, ...}) = 0

                  mmap(NULL, 67050288, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0x7fbb81192000

                  mprotect(0x7fbb84acf000, 2097152, PROT_NONE) = 0

                  mmap(0x7fbb84ccf000, 4055040, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0x393d000) = 0x7fbb84ccf000

                  mmap(0x7fbb850ad000, 879408, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7fbb850ad000

                  close(5)                                = 0