0 Replies Latest reply on Feb 23, 2016 11:44 AM by petrkalos

    OpenCL + Underclocking

    petrkalos

      Hi,

       

      Doing performance evaluation of an OpenCL application that I tried to underclock my GPU,

      only to realise that the clocks are not respected ONLY when I am running OpenCL1.1 applications and ONLY when I am setting the values lower than the default clocks.

      On the other hand underclocking is working as it should when I am doing any kind of rendering.

       

      I can say that the clocks are not respected for OCL apps because of the facts

      • Clock Monitoring Tools (Crimson, GPU-Z, etc...) showing that "current clock value" is always bigger than the maximum target value that I've set
      • Actual performance of the app doesn't decrease even if I set the clocks to minimum possible

      The problem looks very consistent, with every possible combination that I could try.

      • OS: Windows 8.1, Ubuntu 14.04
      • GPUs: 370, 380X, 290X
      • Tried to set the clocks with: AMD Crimson, aticonfig, ADL SDK
      • Always using the latest drivers for each OS

       

      Could you suggest any workaround?