0 Replies Latest reply on Feb 19, 2016 11:15 AM by adrianosoutheast

    MSI R9 390X behaving strangely, crashing

    adrianosoutheast

      Dear AMD,

       

      I have recently purchased an MSI R9 390X. However, the last few days have been positively Hell getting the bloody thing to work! I had bought it to upgrade from my old, but otherwise reliable Asus Matrix Platinum 280X. I have tried clean reinstall of the drivers via utility, manual deletion of the drivers and reinstallation, a disconnected installation of all the drivers and utilities from the in-box DVD to no avail. I have now reverted to my 280X. Please assist me with this. I'd hate to think I just wasted more than 400 dollars for a dead card.

       

      Current System Specs:

      CPU: AMD FX-8320E 8-Core 3.2 GHz

      Motherboard: ASUS AM3+ M5A97

      RAM: Kingston Hyper Fury 4 GB [2 Units]

      SSD: Transcend SSD370 128 GB

      HD: Western Digital 1TB SATA 64 MB Cache Blue

      PSU: VS650 Corsair

      GPU: Asus Matrix Platinum R9 280X (CURRENT)
      GPU: MSI R9 390X Gaming 8G (PROBLEM)

       

      OS: Windows 10 Professional x64

       

      Attached are some pictures that show the kind of warnings that pop-up. The games have been inconsistent in their reception of the card:

       

      Dark Souls - Prepare to Die Edition: Reaches Main Menu fine. When loading the game, I get a black screen and a warning of the driver.

      Civilization V - Loading the menu works, loading the save allows me to reach the loading screen, and as soon as I see "Continue Your Journey" it freezes. Warning pops up.

      Divinity Original Sin Classic - Reaches the menu. Weird green and red lights, and the click of any of the options present brings me to the next screen and freezes the computer. Warning pops up.

      Divinity Original Sin Enhanced - Opening loading screen followed by a black screen and a crash. Pop-up mentions failure to create texture.

       

      I have tried the following drivers: 15.7.1 (From the disc), 15.12 and 16.1