3 Replies Latest reply on Feb 22, 2016 8:29 AM by amdmatt

    R9 380X variable clock speed cause ingame stutter

    dread

      Hello red people!

       

      Recently (Black Friday) I bought a brand new R9 380X from XFX. I had previously a 7970Ghz Ed. that I gave to my brother and I just bought this one which is quite the same as the old one I had but with less heating problems.

       

      Point is that when I play games, I have stuttering, thing that does never happen to the 7970Ghz Ed. under the same circumstances. I have been investigating and this stuttering is being caused by the dynamic adjust of the core clock speed. I have just tested it with Heroes of the Storm (which I get heavy stutter) and the numbers that I got from monitoring my graphics are quite interesting. The whole gaming time, 15 minutes, the card has been making these auto adjustments (1-min time period of that game session):

       

      Time                               GPU Core Clock Speed

      2016-02-20 11:42:00 ,              386.5 

      2016-02-20 11:42:01 ,              501.9 

      2016-02-20 11:42:02 ,              468.9 

      2016-02-20 11:42:03 ,              504.7 

      2016-02-20 11:42:04 ,              423.9 

      2016-02-20 11:42:05 ,              412.4 

      2016-02-20 11:42:06 ,              540.8 

      2016-02-20 11:42:07 ,              462.9 

      2016-02-20 11:42:08 ,              419.0 

      2016-02-20 11:42:09 ,              425.8 

      2016-02-20 11:42:10 ,              396.6 

      2016-02-20 11:42:11 ,              395.4 

      2016-02-20 11:42:12 ,              423.4 

      2016-02-20 11:42:13 ,              488.4 

      2016-02-20 11:42:14 ,              445.1 

      2016-02-20 11:42:15 ,              466.7 

      2016-02-20 11:42:16 ,              634.3 

      2016-02-20 11:42:17 ,              494.3 

      2016-02-20 11:42:18 ,              465.4 

      2016-02-20 11:42:19 ,              436.4 

      2016-02-20 11:42:20 ,              565.4 

      2016-02-20 11:42:21 ,              487.5 

      2016-02-20 11:42:22 ,              472.7 

      2016-02-20 11:42:23 ,              467.1 

      2016-02-20 11:42:24 ,              534.2 

      2016-02-20 11:42:25 ,              494.9 

      2016-02-20 11:42:26 ,              462.8 

      2016-02-20 11:42:27 ,              454.8 

      2016-02-20 11:42:28 ,              411.8 

      2016-02-20 11:42:29 ,              652.0 

      2016-02-20 11:42:30 ,              457.8 

      2016-02-20 11:42:31 ,              573.4 

      2016-02-20 11:42:32 ,              517.2 

      2016-02-20 11:42:33 ,              456.2 

      2016-02-20 11:42:34 ,              475.9 

      2016-02-20 11:42:35 ,              426.3 

      2016-02-20 11:42:36 ,              447.8 

      2016-02-20 11:42:37 ,              403.9 

      2016-02-20 11:42:38 ,              490.1 

      2016-02-20 11:42:39 ,              445.1 

      2016-02-20 11:42:40 ,              432.9 

      2016-02-20 11:42:41 ,              466.0 

      2016-02-20 11:42:42 ,              550.8 

      2016-02-20 11:42:43 ,              519.7 

      2016-02-20 11:42:44 ,              482.6 

      2016-02-20 11:42:45 ,              466.3 

      2016-02-20 11:42:46 ,              502.2 

      2016-02-20 11:42:47 ,              503.8 

      2016-02-20 11:42:48 ,              508.0 

      2016-02-20 11:42:49 ,              426.8 

      2016-02-20 11:42:50 ,              452.0 

      2016-02-20 11:42:51 ,              539.3 

      2016-02-20 11:42:52 ,              518.6 

      2016-02-20 11:42:53 ,              484.8 

      2016-02-20 11:42:54 ,              522.4 

      2016-02-20 11:42:55 ,              458.2 

      2016-02-20 11:42:56 ,              552.0 

      2016-02-20 11:42:57 ,              448.9 

      2016-02-20 11:42:58 ,              458.7 

      2016-02-20 11:42:59 ,              559.2 

       

      Is this even normal? I mean, I know and I'm very grateful that when it is idle the core clock speed goes down to 300Mhz. Less noise, less heat, the graphics suffer lest, etc. But ingame? I want it to be fully maximized to 900Mhz to avoid those stutters.

       

      This happens quite a lot in Black Desert Online. I can't put it to a high quality details because of this dynamic fluctuations. The point is, is there any way to disable this while running some applications? I also have an app for my G19 Logitech that shows me the GPU Load % and it goes all the time from 0% to 100%.

       

      Thanks in advance guys!

       

      PS: I have the latest Crimson drivers installed.