AnsweredAssumed Answered

R9 200 series, problem with 1 game only

Question asked by lutti on Feb 17, 2016
Latest reply on Feb 18, 2016 by lutti

Evening everyone.

I got a new gfx a couple of weeks ago, and today I tried reinstalling a game I haven't played since my old gfx; Diablo 3!

As the game is done downloading, I click "play" in the b.net launcher and WHAM I'm met by a black screen with a blinking cursor but game sound is there and clearly the game itself is working (I can hear the intro trailer, and I can hear it reacts when I click escape and such)

So, I start googling for a solution and try, literally, hundreds of things (amongst that being on live chat with a Game Master from Blizzard for 1½ hour before I got too frustrated to continue - he suggested I should try make a post on here).. Here's the list of what we tried:

Reinstalling the battlenet app and renewing it's configuration files.

Double checking I am not overclocking. (definitely not the problem as I don't even know what or how to do that lol)

Modifying in the D3prefs file - Height/Width to match my monitor, along with toggling fullscreen and vsync.

Deleting the D3prefs file.

Scan/Repair on D3.

Setting D3.exe to compatibility mode.

Ensuring most recent video drivers are installed. (as well as tried older versions, before I contacted Blizzard)

Defragging my drive.

As well as a few other things like reinstalling the battle.net app, the game itself (3 times in total!!) and deleting a few blizzard-folders

Game master, at the end, suggested the following: setting up a new admin user and installing the game there, ensure that Secondary Logon is enabled (whatever the hell that means - he put a link in an email for me ), starting computer in selective startup mode and last suggestion was to post on here

As a very last resort, he suggested completely reinstalling my computer which there is no way in hell I'm doing for a game I know I'll get sick of within a few weeks! lol (plus it'd take of rest of my available data; I'm on a mobile broadband, with 200GB limit per month and I already used at least 50 on trying to fix this damn problem)

I have not had 'any' problems with 'any' other games whatsoever since the new gfx, and I've played quite a few! WoW, Heroes of the Storm, Sims 3+4, SWTOR, Civ V, and probably quite a few others I've unstalled long ago 'cause they were boring

 

Not sure if it's got something to do with it but my AMD Gaming Evolved keeps saying something about a new available driver, 16.1.1, but when I click the link, it just goes to the 15.12 site??

Outcomes