AnsweredAssumed Answered

Linux RHEL/Centos/SL 7.2: How to setup Dual Graphics?

Question asked by teruksor on Feb 15, 2016

Hello

 

My system specifications are the following:

 

OS: Scientific Linux 7.2 64 bits

APU: A10 7850k

GPU: XFX Radeon R7 250 2gb DDR3

Motherboard: Gigabyte G1.SNIPER A88X

RAM: 8gb

Kernel: 3.10.0-327.4.5.el7.x86_64

 

I installed the drivers from the AMD website and are working quite well without any issues. However I can't seem to make the Dual Graphics or CrossfireX work. Here is what I did after installing de driver:

 

As root:

aticonfig --initial --adapter=0,1

 

aticonfig --addch --adapter=0,1

aticonfig --cfa --adapter=0,1

 

aticonfig --mgpu-sls=on --cf=on --adapter=0,1

 

The output tells me:

Warning: No MGPU chain defined for master adapter 1

MGPU_SLS chain(s) enabled

Warning: X needs to be restarted before MGPU_SLS changes take effect.

Warning: No MGPU chain defined for master adapter 1

Crossfire chain(s) enabled

CrossFire does not support on this platform

Warning: X needs to be restarted before CrossFire changes take effect.

 

I restart the system and then lsch and lscs tell me the following:

aticonfig --lsch:

Multiple GPU chain for adapter 0, status: MGPU_SLS is enabled, Crossfire is enabled

  0. 00:01.0 AMD Radeon(TM) R7 Graphics 

  1. 01:00.0 AMD Radeon R7 200 Series

 

aticonfig --lscs:

    Candidate Combination:

    Master: 0:0:0

    Slave: 0:0:0

    CrossFire is disabled on current device

    CrossFire Diagnostics:

    CrossFire can work with P2P mapping through GART

    Candidate Combination:

    Master: 0:0:0

    Slave: 0:0:0

    CrossFire is disabled on current device

    CrossFire Diagnostics:

    CrossFire can work with P2P mapping through GART

 

 

On the Radeon Control Center sometimes I can see the CrossfireX menu option but when I open it there are two options Disable to allow multiple monitors and Enable to improve 3D rendering, but both options are greyed out and I can't change them running it as administrator. The diagnostic page also doesn't really let me do anything either. I have read somewhere that I need to enable IOMMU so I verified it's enabled on the BIOS and also I have tried to add the option "amd_iommu=on" on Grub2. I have two monitors one HDMI and one VGA, I have tried to disconnect one of them but still the same results. So perhaps I'm missing something, but I don't really know what.

Outcomes