10 Replies Latest reply on May 22, 2016 3:30 PM by kingfish

    Windows 10: No AMD Driver installed or not functioning

    stereox

      Hi

      I'm new here.

       

      Here's my specs:

      HP Pavilion g4 tx-1### <- forget the number, but starts with 1

      Windows 10 Pro (Activated, upgraded from my Win 8.1 Pro, upgraded from my Win 7 Ultimate)

      6 gigs RAM (4 gb additional RAM due minimal responsiveness from original model)

      Intel HD 3000 + Radeon 6470M Switchable

       

      Sorry for my English, it's not my native language.

       

      Previously i use Catalyst 15.7 as it's WHQL.

      Got no error until 6 Jan Windows Update ( i forget what update) and it screws Radeon.

      I used GPU-Z to see how much Radeon GPU load when i'm in game, this case is Dota2. On main menu, i used to get >40 FPS, until this update which dropped it to 15 FPS to Single Digit FPS.

      I googled the solution and found UnifL 15.7 fixed this, for few weeks. Until recent windows update on 13 Feb.

       

      This update REALLY gives me hatred to this automatic update. It didn't even notify me on download.

      And moreover, this update revert back my previous problem. And it become more severe, i tried to fresh install both drivers and Catalyst always says that "No AMD Driver Installed or Not Functioning.......".

      The question is, how can i fix this ? I have tried reinstalling drivers many times until i decided to ask here.

       

      Thanks

      Again i am sorry for my bad english.