AnsweredAssumed Answered

R9 380 crimson linux

Question asked by nitror9380 on Feb 9, 2016
Latest reply on Jun 3, 2016 by nitror9380

Hi there,

 

this is my first post - so forgive me if it is not up to standard ...

 

Hardware: Mobo: ASUS P5B Deluxe / Sapphire Nitro G5 R9 380 / OS: openSuse LEAP : linux 4.1.15-8-default,  prior openSuse 13.2

 

I have been using radeon cards for a long time (since XT1650) and after some playing with the parameters always got it to work nicely.

Having said this -- the AMD support is not really helping ... over the years!

The best info's I used and found came from here

https://www.novell.com/coolsolutions/feature/19296.html

 

but this is probably outdated by now, but shows some method to compile and integrate modules ..

 

Now it was time to upgrade 

- after spending quiet a few bucks on the R9 380 card. I have been under the impression that the driver will work with Linux and have a mature but kick A card.

Comment: I fully understand that not everything - can and will work out of the box --- eventhough it should - e.g. NVIDIA can do it)

 

However -- using the latest CRIMSON drivers is a nightmare, that renders your "XSERVER unusuable" creating segmentation faults and so on.

 

What annoys me most - that the driver renders my system unusuable and I have to spend a lot of time to get it back where it was!

Not even the so called uninstall routines (that are hidden in subdirs) work properly!

 

Examples:

1) installation using RPM generated driver never worked flawless, only the driver installation occasionally but not out of the box.

Q: Is it so hard to write a routine doing dependency checks (install and uninstall routines?)

 

2) Comment:

when uninstalling, after using the uninstall.sh - one has to remove fglrx by hand from all over the system

if there is any fglrx present somewhere one cannot get the slow radeon driver to work!

AMD should have a look at:

  Sebastian Siebert | Linux, openSUSE

 

  and his makerpm-amd-15.11.sh script providing a clean install / uninstall method. --- (Script works, but the DRIVER NOT!)

  Lots of INFOS and helping info for the pro's (not me)

 

3) Comment:

In /usr/lib64/libexec/kf5 the "start_kdeinit_wrapper" reports a missing libGL.so.1 which is part of the xfree86 (Xf86... driver and libraries of Xorg)

This has been removed by the uninstall routine for no reason  leaving the system with an error when starting X

 

  error: "kdeinit check your installation error"

 

Solution.: Reinstall the xf86... packages e.g. zypper xf86....  -f (for openSuse)

 

 

So far I have not been able to get the "R9 380" to work properly on a clean installed openSuse (42.1 / Leap)

The radeon driver is slow and hardly nicely usable (and am not talking gaming here! )

 

May be someone can post some Infos on which drivers do work! (Please!)

AND how to get them installed - since not everyone is an IT pro -- to have at least a usable grafik interface.

I think most Linux users do not care about latest drivers, but this card should perform at least - that is why it was bought.

 

Final statement -- #linux #blacklist AMDchips and cards --- or not?

The card is not the latest model - so I expected to have a more mature working setup at least.

In openSuse 13.2 (not new either) - no go, in LEAP (newer) - no go! I am disappointed - big time.

Outcomes