1 Reply Latest reply on Feb 16, 2016 7:52 AM by zealotki11er

    Universal Windows Platform (UWP) CrossfireX

    zealotki11er

      So recently I purchased Rise of Tomb Raider via Windows Store. Unlike Steam which uses Legacy Windows App the Store version is a Universal Windows App. This is a different beast and many of rules and applications do not work well with Universal Windows Apps because not many people use them. CrossfireX was not even a thing until a full AAA game like RoTR hit the Store. This could easily be a Store (Microsoft) problem or even a game problem but I would like to know if AMD has done any testing with UWP apps and CFX. Here are the problems that i am having.

       

      1)When I launch the game with CFX ON I get black screen. I wait and wait and nothing. When I press Windows Key information comes and games loads fine. I run the game Full Screen mode so I can get CFX to scale. I load the game at my current point and again the game stops loading. I have to press Windows Key again. Once I am in the game I click on the screen so I can go back to the app and CFX works fine. This is very annoying because anytime there is loading for new level or even cutscenes I have to press Windows Key. Do this enough and the game crashes.

       

      2) If I ALT-TAB out of the game and go back CFX does not work anymore. Usage drops from 95% to mid 50% and both cards downclock to 7XXMHz. No matter what I do I cant get the cards to fully load again. Pressing ALT+Enter does not help.

       

      Both these problems do not happen with single GPU.

       

      More games are going to come out Store so I would like to know if AMD is going to do something about it and works with game devs or Microsoft.

       

      I have the lastest drivers.

      I made sure to do a fresh install of Windows 10 so it was not a problem in my end.

      Have all the latest updates.

       

      Running 3770K + 2x R9 290 GPUs + 16GB on 240GB SSD.

       

      There are more problems with the game in general but this was only the first 30 mins into the game.

       

      Thanks for looking. This is mostly directed to AMD staff since users probably never had this problem before. There are no solutions for this in the Web.