0 Replies Latest reply on Feb 6, 2016 10:44 AM by solidforger

    Flickering Square Pixels/Triangles on R9 290/latest Crismon drivers

    solidforger

      Hello there,

       

      I've been having a recent issue that's been the cause of a lot of grief in the past week.

      I'm posting this here in hopes to figure out what the hell is going on once and for all.

       

      I've been having flickering pixels all over the screen or on select areas in game (intensity varies from game to game) and a weird triangle flickering glitch that is exclusive to the new Tomb Raider games and is fixed by disabling tesselation.

       

      I've figured it was a driver issue but I've done numerous clean driver installs and all the issues persist in the same games. I suspect something in my system is causing the corruption or it's really down to a faulty GPU, which is what I really dread.

      I also don't recall seeing these issues before the AMD Crismon drivers, even so, they remain even when downgrading to older drivers.

       

      As far as I'm concerned, my GPU temps are normal, usually average around 55 and 69~71c in more demanding games. CPU temps are around 55~61 when stressed.

       

      As for my display, I'm using a DVI cable...but I don't believe it's the cause, since I don't think I'd be able to capture the flicker in a screenshot if it were a faulty screen/cable.

       

      These issues aren't seen in any other games, and they only occur in-game on the following setup and games:

       

      Windows 10 64bit

      ASUS M5A99X EVO R2.0

      Sapphire R9 290 Tri-X OC 4GB (stock clocks)

      AMD FX 8350 (stock clocks)

      KINGSTON 8GB RAM

      CORSAIR TX650

       

      Rise of the Tomb Raider

      http://steamcommunity.com/sharedfiles/filedetails/?id=6...

      http://steamcommunity.com/sharedfiles/filedetails/?id=6...

       

      The Witcher 3

      http://steamcommunity.com/sharedfiles/filedetails/?id=6...

       

      Assassin's Creed Unity

      http://steamcommunity.com/sharedfiles/filedetails/?id=6...

       

      tesselation dark triangle flicker:

      http://steamcommunity.com/sharedfiles/filedetails/?id=6...

      http://steamcommunity.com/sharedfiles/filedetails/?id=6...

       

      Things I've done so far to try to fix the issue:

       

      1.Clean driver re-installations (used DDU in safe mode etc):

      Omega 14.12, Catalyst 15.11, Catalyst 15.11.1, Crismon 16.1, Crismon 16.1.1

       

      2. Upgraded my OS to Win10 64bit (previously Win7 64bit, had the same issues)

       

      3. Ran 3Dmark11 to find if the issue was related to Dx11, worked perfectly

       

      4. Ran a Furmark GPU stress test for 20 minutes, had no issues, my max temp was 71c

       

      5. Placed my RAM modules in alternate slots, though I highly doubt it's related to memory

       

      8. My card has a BIOS switch, I've tried tampering with it to no avail

       

      Any ideas? Any help will be greatly appreciated!