0 Replies Latest reply on Feb 5, 2016 4:54 PM by joko013

    Cannot install new GPU drivers

    joko013

      Hello,

      I have a little over 5 years old laptop (Acer Aspire TimelineX TG3820) that as some laptops has 2 graphics cards, one integrated and ATI Mobility Radeon HD 5650.

      Some time ago I wanted to restore factory setting because during those 5 years of use I never properly cleaned the laptop. So I did and with that the system restored some old factory pre-set driver of the AMD card. After this everything worked fine but few days ago I started having weird FPS drops while playing Heroes of the Storms. As I checked, it's not ping related so it's probably hardware related.

      So I did what every forum suggests, I tried updating my graphics card drivers and here comes my problem.

      Every time I install a new driver using AMD CCC (so far I tried 3 different versions from the newest to some older ones) this happens: During the installation, the screen flashes (just like when you unplug the laptop from the power source and it switches the gpus) and the resolution of the screen changes to something like 640*480. The installation finishes and I proceed with restart. After the restart two things can happen 1) either the system starts in this horrible resolution and I can check in the system properties that it's using the integretated card and it won't switch to the AMD card. (this is the case for the newest CCC and the older one) Or and this is the case for the Crimson Beta driver: 2) The system boots looking fine and after logging in and another 1-2 mins in Win the error that Radeon utility stopped working (or something like this, sorry, I did not printscreen this...) and it offers me to either Resolve the issue and close the program or Close the program right away option and after that it again switches to the integrated gpu.

      So my question is: Has anyone encountered this kind of problem? Any solutions? I tried google-ing but nothing so far.

      Any help is appreciated.