16 Replies Latest reply on Oct 6, 2016 12:50 AM by radeon_user88

    Fallout 4 downclocking

    jochemr

      UPDATE:

      I've found a workaround using RadeonPro: http://www.radeonpro.info (may work on other applications as well)

      Quick How-To:

      - Download & Install RadeonPro

      - Open RadeonPro and create a new profile pointing to Fallout4.exe

      - In the 'Overdrive' tab check 'Enable graphics overdrive' and 'Always use high performance clocks while gaming' (<< this one actually forces the proper clock speeds onto the GPU)

      - Apply these settings

      - Launch Fallout4.exe with RadeonPro running (NOT the launcher, you need to run the game executable or else this workaround won't work)

       

      Hope this helps!

       

      Original Post:

      Hey everyone, i have an issue with my GPU clockspeeds and was hoping you could help.

      So i recently got Fallout 4, started playing it on the suggested 'Ultra Quality' preset and noticed major FPS drops, especially inside. Thinking i was just asking too much from my GPU i switched to the 'High' preset. Same problem. 'Low' preset. Same problem. Started tweaking quality settings myself, a few hours later still having the same problem.

      I decided to have MSI afterburner run in the background. After running around a bit in the Museum of Freedom i checked the graphs. This is what it looks like:

      As you can see, the clock speeds flucutate quite a bit and almost never reach the intended (stock) 980Mhz. In fact, it won't reach 800.  (Terrible framerate drops everywhere)

      "But what if I increase the load?" I thought. So i fired up AMD Gaming Evolved, enabled Game DVR, started recording and guess what, 60fps with no drops whatsoever. My clock speeds also stay at 980Mhz during gameplay:

       

      So my question of course is: How do i fix it? I've tried increasing the power limit, frame rate target control and whatnot to no avail. I'm eager to hear your suggestions.

       

      My System:

      CPU: Intel i5-4460

      Motherboard: MSI B85-G41 PC Mate

      GPU: Gigabyte R9 380x @ 980mhz

      RAM: 2x4gb 1600mhz G.Skill Ares

      Display driver: Crimson 15.30.1025.1001

      Display device: BenQ GW2270 1080p60 through DVI-D

      700W PSU

       

      Thanks in advance!

      - Jochem

        • Re: Fallout 4 downclocking
          amdmatt

          Thanks for raising this. We are aware of it and are continuing to investigate the issue. ray_m

            • Re: Fallout 4 downclocking
              jochemr

              Thank you for tour response! Glad to hear it's being worked on.

               

              Meanwhile I've found a somewhat more elegant workaround: using RadeonPro you can force the gpu to run at the maximum clock speeds in certain applications. All is smooth now (yay)!

               

              (Also applies to applications besides FO4)

                • Re: Fallout 4 downclocking
                  donta1979

                  Yup same issue here with it downclocking. Trying to figure out RadeonPro with Fallout 4 right now actually.

                    • Re: Fallout 4 downclocking
                      jochemr

                      Updated post with instructions, let me know if it works

                        • Re: Fallout 4 downclocking
                          donta1979

                          Yup between that and the other fixes I am now getting smooth as butter FPS everywhere in game. Made a guide I posted on the Bethesda forums and about to on steam. Linked the last piece of the puzzle you found on this post.

                           

                          http://forums.bethsoft.com/topic/1588492-guide-for-improving-fallout-4-performance-on-amd/

                          This guide is to help those with AMD that have cards that should be getting a nice steady 50-60 FPS, but keep hitting a wall.

                           

                          First lets cleanup and get the latest drivers Crimson 16.1.1 Hotfix

                           

                          Latest AMD Crimson Drivers 16.1.1 Hotfix

                          Before you install the latest drivers I would suggest a clean install use both the AMD Clean Install Utility followed by DDU

                           

                          Between using RadeonPro, Shadow Boost . First you need to set the game to use 4 cores or however many cores your cpu has and priority using the Fallout 4 Configuration Tool I am getting about a steady 57-60 FPS. If you want to try shadow boost"I highly suggest it" its a big help make sure you set your shadow distance to Medium in game launcher, then in the shadowboost INI my sweet spot for my hardware ill post below. Unless they make it use multi/cores and threads or done on the GPU no one will be able to run Ultra Shadow Distance nor get 60 FPS without shadow boost to help with the transition dynamically changing shadow distance. So if you want to maintain a nice 50-60 FPS and still have your game looking good Shadow Boost is a must.

                           

                          Set tessellation in Crimson Global to override, set it to 6x, have not tried setting it back to AMD optimized or 8x or 16x again yet.

                           

                          God Rays unfortunately we cannot turn off in the latest patch game puts them on auto low.

                           

                          Using HBAO+ seems to increased my min FPS over the other method.  The shadows unfortunately are tied to Bethesda's old method...

                           

                          We need to bombard Bethesda to implement GPUOpen honestly better than gameworks, opensource, and both AMD and Nvidia gpus can use it, with it being open source it will let Bethesda make performance improvements directly for both Card Manufacturers.

                           

                          Those that wish to use TAA because it takes care of the major AA issues in the game but the texture blurring is drive you crazy you will need to get Reshade

                          Then follow this reddit post to apply LUMASHARPEN - SweetFX to unblur the textures.

                          1. Download the ReShade Framework package and extract its contents. http://reshade.me/#download

                          2. Launch Mediator.exe under the main ReShade directory.

                          3. Click the Add button, browse to C:\Program Files (x86)\Steam\steamapps\common\Fallout 4, and select Fallout4.exe and click Open.

                          4. Make sure Direct3D 10/11 is selected, and click the Confirm button.

                          5. Now close the Mediator utility, and launch it again, then select Fallout 4 from the drop-down box.

                          6. Select the Pipeline tab, then tick the 'LUMASHARPEN - SweetFX' box.

                          7. Click the 'LUMASHARPEN - SweetFX' text itself to open the sharpening settings. Raise the 'sharp_strength' slider to 2.0 and click the Apply button at the top right. You can come back and re-adjust the strength of the sharpening later to better suit your taste.

                           

                          ShadowBoost.ini

                          [MAIN]

                          fTargetFramerate=57.0

                          fDistChangeSpeed=5

                          fShadowDrawDistMin=2000.0

                          fShadowDrawDistMax=7000.0

                           

                           

                           

                           

                          Now for Radeon Pro setup to keep your gpu from downclocking in the game increasing performance inside and outside. Here is the Original Post

                          I've found a workaround using RadeonPro: http://www.radeonpro.info (may work on other applications as well)

                          Quick How-To:

                          - Download & Install RadeonPro

                          - Open RadeonPro and create a new profile pointing to Fallout4.exe

                          - In the 'Overdrive' tab check 'Enable graphics overdrive' and 'Always use high performance clocks while gaming' (<< this one actually forces the proper clock speeds onto the GPU)

                          - Apply these settings

                          - Launch Fallout4.exe with RadeonPro running (NOT the launcher, you need to run the game executable or else this workaround won't work has to be done each time you play)

                           

                           

                           

                          If the game is crashing remove all your game changing mods, like weapions/armor/settlements/game mechanics. Next depending on what version of windows you have you will need to remove the Fallout 4 config files. Documents>My Games>Fallout 4 Remove all INI files in that directory, now go to your steam folder Steam>steamapps>common>Fallout 4

                          You will need to delete the Fallout4_Default.ini then there should be a Folder called Fallout 4 in your Fallout 4 directory go into it, now delete the Fallout4Prefs.ini as well.

                          Once you do this Launch the game via steam, let the Fallout 4 launcher scan and configure the game, Once it is done go into options, set your Shadow Distance to medium, turn Godrays to low, set the depth of field to low, uncheck motion Blur.

                           

                           

                          I just had someone who has an AMD R9 390 do all of this and his game is now running butter smooth just like my Fury X. This should help a ton of you out there.

                            • Re: Fallout 4 downclocking
                              zerowalker

                              You might wana look into ClockBlocker as well, pretty much better than RadeonPro at this kind of stuff:)

                              At Guru3d

                                • Re: Fallout 4 downclocking
                                  donta1979

                                  clockblocker will just run a process that does not affect the game, RadeonPro actually does it for the EXE with the overdrive force making Fallout 4 run nice and smooth indoors and outdoors unlike clockblocker. The only thing clockblocker is good for is avoiding the screen corruption bug.

                                    • Re: Fallout 4 downclocking
                                      zerowalker

                                      ClockBlocker will force the Card to for example, always run at max clocks if a fullscreen application is up, or your own specific rules.

                                      No need to setting RadeonPro on every exe, ClockBlocker do this automatically, should work precisely if you use ADL method:)

                                        • Re: Fallout 4 downclocking
                                          donta1979

                                          Go read the notes from clockblocker's creator. It opens up a background task that just makes the GPU clocks jump up. It won't force a game or even an application to take advantage of it. I know I have tried. It's great for screen corruption or games with lower older graphics to not get screen corruption that is it. It does not force the executable directly with an overdrive to take advantage of the increases clock speeds like RadeonPro. I tied clocklocker with Fallout 4 and Maya it didn't give any performance improvement. RadeonPro actually does. This is part of the issue I see on AMD side so much misinformation to the point it clouds the truth to real viable fixes and solutions. Clockblocker does not improve performance on Fallout 4 nor offers any benefit in game performance in fullscreen or windowed that I have seen the past 30 days on my own quest to get Fallout 4 fully playable and smooth.

                                      • Re: Fallout 4 downclocking
                                        jochemr

                                        Both RadeonPro and ClockBlocker work, however RadeonPro supports over/underclocking while clockblocker only allows running at factory clockspeeds (I prefer RadeonPro for this reason). Thanks for your input though

                                          • Re: Fallout 4 downclocking
                                            zerowalker

                                            Ah, you mean specific overdrive mode?
                                            That's very true, thought you just were interested in "prevent downclocking", which ClockBlocker (as the name states) is made for;P

                                             

                                            But just glad i could give some information that might have been of any use, thanks for the appreciated response:)

                                              • Re: Fallout 4 downclocking
                                                donta1979

                                                Yeah i love clockblocker for its anti screen corruption capabilities, I have had no luck with it improving performance in games and apps.  Have to use the OP's option to get performance in my games and apps that only RadeonPro is offering.

                                                  • Re: Fallout 4 downclocking
                                                    zerowalker

                                                    I actually had good experience when it comes to frame timing.
                                                    I had 60fps but the clock were like super low, 300-600mhz (985mhz max).
                                                    And i thought it was weird that it was so stutterish.

                                                     

                                                    However running at max clock completely fixed though timings:)
                                                    But then again, that's precisely as RadeonPro would. But it's one of those "Downclocking" stuff i dislike.

                                            • Re: Fallout 4 downclocking
                                              radeon_user88

                                              Hi donta1979, this may be an old post but I wanted to thanks you for the guide, very helpful !

                                    • Re: Fallout 4 downclocking
                                      triasalt@gmail.com

                                      After correct uninstalling 16.1, and install Radeon Crimson 16.1.1.

                                      Included Crossfire 60-80 fps, but the texture disappear. Is a pity, delighted Crossfire. I had to turn off the Crossfire settings.