4 Replies Latest reply on Jan 27, 2016 7:02 AM by goat

    Msi Radeon r9 390.

    goat

      Hello AMD people!

       

       

      Ive recently bought this lovely card (Msi radeon r9 390) at first this card performed very nicely, but lately ive expriencen dropping fps basicly in all games (Fallout 4, Witcher, Dota etc etc) and the sound in some games are shattering.

       

      It first happen when i updated the driver, so i uninstalled it and installed crimson 15.11.1 and that helped alot, but after a few days it started to happen again.

       

      Does anyone have any tips or advice?

       

      Speccs:

      794859Seagate® Desktop SSHD 1TB1
      812880HyperX Fury DDR3 1600MHz 16GB Black1
      819931MSI 970 GAMING, Socket-AM3+1
      823713AMD FX-8370 Black Edition, Socket-AM3+1
      852514Cooler Master Nepton 120XL CPU Cooler1
      796967Corsair RM750, 750W PSU1
      847416MSI Radeon R9 390 Gaming 8GB GDDR5
        • Re: Msi Radeon r9 390.
          goat

          Also i noticed that the clock speed on the GPU is only on 300-400 when im in-game such a The witcher 3, should it not be on like 700-1000mhz while in such a game?

          • Re: Msi Radeon r9 390.
            amdmatt

            Please uninstall Crimson 15.11.1 and try updating to the latest Crimson driver, 16.1 Hotfix available here.

            • Re: Msi Radeon r9 390.
              kingfish

              Are you using Windows 10? If so, you need to disable Microsoft's automatically installing what it considers to be the correct/current drivers > Windows 10 keeps downgrading AMD drivers  Also, you need to be using the latest Public release of Windows 10....not the fast/beta versions. Does the computer device manager show any yellow marks?

              Do you have Overdrive enabled and the Power Limit of your GPU raised to the maximum + value? (It will be either +20 or +50).

              Some additional ideas...> AMD graphics performance

              1 of 1 people found this helpful
                • Re: Msi Radeon r9 390.
                  goat

                  Yea i am using windows 10 but for some reason my updates are stucked and wont install, so i guess thats fine.

                   

                  I have no yellow marks in device manager. ive also enable overdrive and everything is almost maxed out, still no effect in-games

                   

                  Ive just format my pc and installed every driver needed, tryed old amd drivers and new drivers still having the same issue

                   

                  my perfomance in-games are horrible(10-30 fps in game), (20-30 fps main menu in gmaes), but in other programs 3Dmark everything is far beyond good

                   

                  My temp are OK 40 °C idle and 70°C underload.

                   

                  Im beginning to think that my PSU aint strong enough?