2 Replies Latest reply on Jan 20, 2016 3:21 PM by violet_hippos

    How to reset a VGA's setting - solved.

    violet_hippos

      I encountered a major problem with the AMD Catalyst caused by a malfunction that it had built in. I solved the problem by myself, as the advice provided by the internet (AMD site or others) couldn't help. I write it here, so it can be referenced by other users that face the same problem. I've seen people complaining (not necessarily in "community.AMD.com") about the same issue.

       

      Notice : I say AMD drivers, because they have many names (Catalyst, Crimson).

       

      PROBLEM :

      You start your PC, you see BIOS as normal, you see Windows to start normally, but then, the AMD driver comes alive (before you may log in) and either crashes the system (not my case) or sends an invalid signal to your monitor and your monitor says that incoming signal is invalid. You want to reset your default AMD settings for the monitor, but you cannot.

      > If you use an another monitor with different specifications, it will work properly, as it has a different setting.

      > If you use an another cable (f.e. VGA instead of DVI) it will also work, for the same reason.

      > If you use safe mode, your monitor will also work.

      > If you un-install the AMD drivers, the monitor will also work.

      - However, if you re-install AMD drivers the monitor won't work (error message or crashing).

      - The AMD Clean-up Utility won't work.

      - The advice of manually removing AMD Graphics elements from the PC (\ - \Windows - \Users - \Programs - \AppData etc) and the Windows Registry won't work.

      - Other unofficial AMD drivers removing tools won't work.

      - Trying settings through Windows menus won't work.

      + Un-install AMD Drivers. Restart your PC, press F8 early (many times, if needed) to enter Windows special boot settings (I did that on Windows 7x64). Choose 640x480 mode. This resets the default setting. Install AMD Drivers again. Reboot and you are ready.

       

      Personal notes :

      I did not try to overclock my system. I've read that this is a possible cause to the problem. I pressed the "swap main display" button on Catalyst and this caused me the problem. The button was available only when multiple monitors were connected. I had pressed it twice before and nothing malicious happened. I have no idea what caused this malfunction.

      However, it is not cool to try to erase a setting and not be able to. I have noticed that in Crimson this button is no longer present. I haven't had a format for years, and I almost had to have one now, because of a serious hole in the AMD drivers (Catalyst). I always protect my system (Genuine Windows with updates and Anti-Virus/Firewall software), and this was by far the strongest blow on my system.

      Not cool AMD, not cool at all. As I write on my brief profile, I suggest people what to buy, and always choose reliable equipment. Next time someone will ask me for a VGA Card, what should I suggest? If I suggest an AMD chipset, I am afraid I may embarrass myself. Please don't leave your drivers exposed to such vulnerabilities. It took me 18 hours to fix it. I didn't have that much free time today. It was awful. Really awful.

      Also, Crimson doesn't let me choose my language of choice (English).