AnsweredAssumed Answered

age of empires 2 hd keeps crashing

Question asked by denkan4sure on Jan 16, 2016
Latest reply on Jan 16, 2016 by denkan4sure

Hey,

 

I recently bought Age of empires 2 hd through Steam but I just don't seem to be able to get it running properly and after some discussion on the steam page I got in touch with others having the same problem using the same AMD GPU.

 

What happens?

 

The game launches just fine looks good until I try to start a game, standard single player or campaign. In a standard single player game the crash happens immediately after it starts, but in a campaign I manage to play for like 20-30 minutes before the game freezes and my computer reboots all by itself.

 

So why do I think it's the GPU causing the problem?

 

I've tried many different things to solve this problem by searching on the forums and google including:

 

* Uninstall and reinstall the game

* Uninstall and reinstall steam

* Uninstall and reinstall Windows 8.1

* Upgrade windows 8.1 to 10

* Verify integrity of game cache

 

Nothing of these things solved the problem so I continued browsing the internet for a solution and stumbled upon someone's advice to disable the graphic card through the device manager and reboot, which I did and the game ran like any other game I usually play (CS:GO, Starcraft, LoL, Hearthstone, Rocket League, Farming Simulator) except for the heavy lag caused by not using the real GPU. So my GPU must be a part of these crashes.

 

Here's my system specifications:

Mobo: MK Asus M4N98TD EVO* AMD 980a, AM3, ATX

CPU: AMD Phenom2 X4 965 3,4Gh 8MB,125W, AM3, BE

GPU: GK ATI Gigabyte HD7870 2GB

PSU: PSU Fractal Design 550W Tesla/550W/80+

RAM: 8gig

 

GPU driver: Radeon software crimson edition (16.1)

 

I would really appreciate if you would take some time looking at this problem.

Outcomes