AnsweredAssumed Answered

LoadLibrary failed with error 87: The parameter is incorrect Crimson Edition 15.12

Question asked by michformer on Jan 14, 2016
Latest reply on Jan 23, 2016 by smgjohn

Hello,

 

I'm currently running into an issue that prevents me from launching certain applications that used to work with pre-15.12 AMD Drivers. Ever since I installed the latest AMD driver, I keep running into the same issue when I try to launch programs like Ren'Py, Photoshop and Wolfenstein: The New Order/Old Blood.

 

error87.png

 

I keep getting the same error message no matter what I did to fix the issue. I tried to use a .reg file to rewrite bits of code related to OpenGL, and even added a .bak extension to atig6pxx.dll to get rid of the problem. Alas, none of those fixes worked. When I tried the 16.1 hotfix, the error message disappeared, but the same applications still failed to launch and other programs/games like The Darkness II stopped working with 16.1.

 

I know this is an ATI and/or OpenGL-related driver issue, but there doesn't seem to be a way to fix it. I'm even thinking of reverting to an older driver in order to get rid of the issue. Any help would be greatly appreciated.

Outcomes