4 Replies Latest reply on Jan 16, 2016 5:10 AM by juris

    R9 290 2 Way Crossfire Issue with Crimson

    discocam

      I have 2 reference designed R9 290s in my rig (4790k, 32gb ram, Asus WS board). Since I updated to the 15.x drivers for the cards (Crimson), I been having issues with crossfire. When the machine starts up, both cards are on whereas only 1 used to be on. By on I mean that the secondary card is running at full clock with the fan on. The fix is to disable and re-enable crossfire it Catalyst, then it works properly until the system is shut down and restarted. Any ideas?

      Thanks.

        • Re: R9 290 2 Way Crossfire Issue with Crimson
          amdmatt

          Download Sapphire Trixxx, select Disable ULPS from the options menu and restart your system. Now do the same again but this time untick disable ULPS and restart the system. Has that resolved the issue?

          • Re: R9 290 2 Way Crossfire Issue with Crimson
            siggurd

            Getting this exact same issue myself ... I have basically the same system setup as you as well ... uhg.

             

            As well as the same issues you mention, I have installed and re-installed all the latest drivers, including the latest hotfix 16.1, and nothing is working.

             

            I cannot force crossfire now, and AFR and anything else I try to enable in profiles for specific games is not working.

             

            FFXIV, Rainbow 6 Siege and other games that were working with crossfire no longer work (though the graphics distortion issue with Rainbow 6 is fixed now with the latest hotfix).

             

            Please just give me back force crossfire option, why would you even remove that?!

              • Re: R9 290 2 Way Crossfire Issue with Crimson
                juris

                I had similar issues. Crossfire would not enable in some games such as Elite Dangerous (which has no dedicated profile but did previously work in 1x1) and as many were reporting the tick box in catalyst additional settings to enable crossifre for games without profiles was simply missing. I tried to reinstall 16.1, removed everything with DDU and also the inbuilt uninstall option with the AMD drivers then went back to 12, then 11.1 beta. No joy.

                 

                Then I ran the AMD Clean Uninstall Utility and reinstalled 11.1 beta after. Now Crossfire is back and working perfectly. Why even the latest DDU isn't clearing out everything is weird but I'm sure they'll fix it soon. Until then run ACUU.