skp119

ATI mobility radeon HD 5430 is missing on device manager and replaced by Standard VGA graphic adapter

Discussion created by skp119 on Jan 6, 2016

I've installed FIFA 15 and then suffered a lag when running. As my experience, I wanna reduce the resolution to make it faster. When I ran fifaconfig, there was a pop-up said that I had to upgrade the graphic card driver to 14.0 version or above. (I was using version 13.2 at that time and OK to play FIFA 14. My graphic card is ATI mobility radeon HD 5430)

 

After that I looked for the driver on AMD website using their autodetect utility. My graphic card still detected as ATI mobility radeon HD 5xxxx and they gave me the 15.7 version of driver.

 

I installed that driver. After finished, it required a reboot. When it was rebooting, before moved to windows, there was a message "missing operating system". But when I did the hard booting and turned my laptop on again, there was no problem. When I tried to play FIFA 15, the game didn't wanna run. Then I tried to play spider solitaire, it also became bad (lag and have opaque appearance). I also checked my graphic card on device manager and I was shocked knowing that my graphic card is missing! My ATI mobility radeon HD 5430 had replaced by Standard VGA graphic adapter.

 

I tried another version of driver (14.4, back to 13.2, and even back to original driver from dell's website) and it didn't work. Now, everytime I restart my computer, there is a message "missing operating system before enter the windows. But if I shut it down and then turn it on again, there is no problem, it looks normal. How can I get my graphic card back again? (I'm using Dell inspiron N4030 with windows 7 64-bit OS)

Outcomes