AnsweredAssumed Answered

RAID5 can't rebuild on Windows 10

Question asked by yurtesen on Jan 5, 2016
Latest reply on Jan 24, 2017 by yurtesen

I have a board with 990fx chipset. The bios set to load legacy driver for raid. System works now with 2 drives. (1 dropped out)

 

Today one of the drives got disconnected from the raid array. I went to raidxpert and tried to rebuild. It just froze.

I rebooted the box and it wouldn't reboot properly. Windows was freezing at login prompt. I disconnected the drive which was out and windows booted fine.

I went to raidxpert and reconnected drive, drive appeared in raidxpert and then tried to rebuild the array. It just freezes when I try that. Then I have to disconnect the drive again so I can boot back to windows 10.

 

I tried different same size drive, also tried different SATA port and different cable. Results are always the same...

 

In device manager I see AMD 2+1 Disk SCSI Disk Device with driver version 10.0.10586.0 and AMD AHCI Compatible RAID Controller with driver version 3.4.1540.2

I tried to install new crimson drivers which said it has drivers for 990fx specifically. The installer does not show any raid drivers to install, also tried raidxpert and it just does not show it. There are other threads here on the forum where people have similar problems. I went to driver folders in the installer and tried to find the driver manually. But all I can find is windows 7 drivers. The windows 10 drivers are only for bolton chipset apparently.

 

So, now I don't know if the issue is the windows 10 or not. Before trying to install windows 7 to try this, I thought I would come and see if you guys have any solutions for this ridiculous problem.

I wonder if AMD cares?

 

Thanks!

Outcomes