AnsweredAssumed Answered

Problem with Asus Radeon R9 270x and W10?

Question asked by lilaam on Dec 30, 2015
Latest reply on Dec 30, 2015 by t77chevy

Hi! Sorry in advance for my English.

 

So I've recently bought an Asus Radeon R9 270x and it seemed to work for like 2 months. Then around November there was an update and it stopped working. I decided to format the computer and do a clean installation but still the same. I even switched between Windows 8.1 to 7 and to 10.

Basicaly, everytime I turn on the computer, there is the windows 10 logo loading and then it freezes, even the lights in the keyboard turn off. With W 8.1 and 7, the screen turned black or got disconnected. Now the only way to turn on the computer is to unplug the graphic card and use the integrated one instead. I am able to enter into safe mode using the Radeon card, but I can't install anything from there. Actually, the device manager shows a simple and basic driver for the Radeon card.

I've also tried previous drivers (that automatic detection by amd, version 15.11 and 15.12) without results.

I don't know if the card is just broken or it's something about the drivers, or what. It's really frustrating and I hope someone can help me.

 

Thank you so much in advance,

Lila

Outcomes