4 Replies Latest reply on Dec 23, 2015 4:38 AM by beastlybanana

    Crimson does not start



      I just updated to AMD Crimson from CCC and I can't get the settings window to open. I uninstalled CCC and all drivers with the utility tool to do that and installed Crimson afterwards. As I said, when I launch it nothing happens.

      Any help would be appreciated, thanks.


      I am running it on Win 7 64 Bit btw.

        • Re: Crimson does not start

          There are two versions of Crimson Edition driver and each supports different graphics cards. Can you tell me the file name of the driver that you have installed and also the model of your graphics card?

            • Re: Crimson does not start

              I installed:



              My graphics card is a R9 285.

                • Re: Crimson does not start

                  Please try downloading and installing Visual C+ 2013. If you already have it installed it will offer you the option to repair the installation. Please do this then run Windows Update and allow it to install any updates.


                  Has that resolved the issue?


                  If the issue persists, please try installing the cnext package again. Navigate to the program directory listed below in the screenshot and run the installer marked in the screenshot.




                  If the issue persists after the above steps, I would recommend using DDU to sweep your system of AMD drivers. Download it, extract it, run it, follow the prompt to restart to safe mode and then click Clean and Restart. This, combined with the steps above should resolve the issue and allow you to perform a fresh installation of Crimson 15.12.

                    • Re: Crimson does not start

                      I repaired Visual C+ 2003, that did not change anything though. I tried updating windows and realized that it had somehow been unable to update for quite a while. So I fixed windows updater and installed all the updates. After that Crimson runs just fine.


                      Thank you very much