AnsweredAssumed Answered

Problems in some games

Question asked by altaier91 on Dec 19, 2015
Latest reply on Dec 21, 2015 by altaier91

Hello everyone ! i am having some problems with 2 games i tried to play: Torchlight 1 and Path of Exile.

 

When i try to play these games my system crashes in the following ways: sometimes my screen is full of artifacts like in the picture below, and sometimes screen goes black and fans start spinning like crazy, both errors having in common a "metalic" buzz sound in the speakers. Before these 2 games i played Mad Max with all graphics options set to the highest possible and nothing happened, everything went smooth. I have reset the system everytime the crash happened, and the last thing i saw in Event Viewer was "AODDriver4.2 service failed to start". I googled this error and some people said that they fixed this by deleting registry entries  HKEY LOCAL MACHINE/SYSTEM/Controlset001/services/folder entry. I tried Path of Exile again, it crashed again and this time it says Event 41, Kernel Power. It's kind of driving me nuts. I thought it was win 10 having some problems...

 

Things i have tried:

- ran memtest86+ for 3 hours and everything was ok ( i didn't test for every ram separately)

- went from windows 10 to windows 8.1 (i thought maybe it was an os problem) and installed last driver ( Crimson) - still had crash

- installed last driver before crimson ( 15.7.1 ) - still had crash

- tried with xmp activated and deactivated ( cause my mobo won't see the full frequency of ram) - still had crash

 

This is my configuration:

 

Power Source: Inter-Tech Energon 750W

RAM: Corsair Vengeance 8GB DDR3 1600MHz CL9 Dual Channel Kit

Processor: AMD Vishera, FX-6300 3.5GHz box

MoBo: GIGABYTE GA-970A-DS3P rev 2.0

GPU: Sapphire Radeon R7 370 NITRO OC 4GB DDR5 256-bit

SSD: Patriot Blaze Series 120GB SATA-III 2.5 inch

HDD: Seagate Desktop HDD 1TB 7200RPM 64MB SATA-III

 

Other weird stuff encountered... The ssd (in which i have windows installed) sometimes freezed when windows was updating... and if i tried to reset, bios couldn't find the ssd to boot from it, so i had to force shutdown and start again everytime. I don't know if this has something to do with the game issues.

 

If someone knows a solution, or other tests that i should run please respond. Thank you in advance and sorry for bad english or any mistyped words.

 

12388103_614638718674403_1310999156_n.jpg

Outcomes