2 Replies Latest reply on Dec 19, 2015 10:58 AM by rezznt

    BSOD thread_stuck_in_device_driver installing drivers

    rezznt

      Graphics Card
      -Powercolor r9 390, no overclocking

      AMD Catalyst Driver Version, and Driver History- include driver version currently used, and version(s) tested previously

      -15.201.1151.1008, although these black screen after a few minutes of use in the desktop.

      Operating System

      -Windows 10 x64

      Issue Details

      -I recently built a new computer, just downloaded the newest drivers from AMD's website (crimson 15.12) and I can't install them without getting a BSOD (THREAD_STUCK_IN_DEVICE_DRIVER). I couldn't install the previous version either, same deal. I couldn't even install the most updated version of CCC drivers. The only drivers I could get that I think might be stable, are the ones installed via windows update.

      -However, pretty much all the drivers I've tried do either one of two things, they either black screen within a couple minutes of use, OR they don't even let me install them and I get a BSOD.

      Applications and Games

      -I haven't installed any games, new computer.

      CPU Details
      -Intel i5 6500, no overclocking

      Display Device(s) and Connection(s) Used
      - Nixeus NX-VUE24A

      Motherboard or System Make & Model
      - ASUS z170 A

      Motherboard BIOS Version
      - ASUS BIOS 1302

      System Memory Type & Amount
      - Kingston 8g x 2

      Power Supply
      -EVGA 1000W Gold G1

      Additional Hardware
      -500g SSD, 1TB HDD, although at the moment I'm only booting from the SSD

      Additional Details- include information about any system checks that have already been done to ensure the system is clean of viruses, spyware, etc..
      -I haven't installed any software yet, I'm still trying to get all the drivers installed.

      -I have disable onboard graphics in the BIOS, although the issues were still present before I did.

      -I've tried installing Crimson Drivers while offline, it didn't help.

        • Re: BSOD thread_stuck_in_device_driver installing drivers
          waltc

          Could be any number of things...as this is a newly assembled system, I gather.  What comes to mind first is the PSU...check cabling to make sure it is attached properly.  Make sure that the proper connectors are connected to the R9 390, as well.  If so, next step is to install an older GPU to verify that it will work as well.  None of the drivers you have used is "unstable" to the point of being able to crash your system by itself--it sounds like a hardware problem of some kind.  You'll want to review the entire assembly looking for a mistake somewhere.  The drivers by themselves would never do this in the absence of any hardware problems.

           

          Check your ram settings as well in the bios to make sure they are correct (very important)--and if none of the above works you might try pulling out a single DIMM if you can.