8 Replies Latest reply on Jan 8, 2016 10:55 PM by drew_eh

    Cannot install AMD Application

    drew_eh

      Hello,

       

      I have had this issue since I first bought my first AMD product and never bothered trying to fix it till now.  Maybe a year, or year and a half now.

      Video Card: AMD Radeon R7 200 Series

       

      Issue:

      Whenever I try to install the latest (happened on 1st install too) driver and application package offered I get the same error message at 2% (talks only a few seconds):

         Application Install: install package failure!

       

      Background

      Currently I have Windows 10 x64

       

      Latest package that I tried to install was for driver 15.300.1025.1001 (released around mid Dec 2015) which also included a new crimson version (not sure what that is all about yet).  If I run the installer, get the error mentioned above, then run the installer again it shows a window with check boxes saying which packages I can choose to install, and what current version I have, here is what it reports (so I know some things have been installed):

      AMD Display Driver - installed - version 15.300.1025.1001

      HDMI Audio Driver - installed - version 10.0.0.02

      AMD Settings - not installed

      AMD Gaming Evolved App - not installed

       

      Things I have tried and failed miserably...

      A) Run as administrator - no effect (I am an admin of my computer anyways)

      A) Add Remove Programs - I cannot uninstall catalyst control center (no error or popups, just doesn't seem to start to uninstall)

      B) Google said to try to edit C:\AMD\radeon...\config\installManager.cfg to say "WorkaroundInstall=True" - no effect

      C) Found "AmdCleanUpUtility.exe", ran it successfully, it did NOT clean up CCC mentioned above (and is still visible in add remove programs), rebooted, try to re-install, same issue occurs

       

      And here I am wondering what to try next.  I do not see any other types of video card software or drivers installed.

       

      Any tips is appreciated.  The driver does install and update fine so I have no idea what this AMD software will do for me, or maybe it will just slow my computer down more, not sure what I'm missing out on.

       

      -Drew

        • Re: Cannot install AMD Application
          john007

          Hello,

           

          I believe you have to be offline to install crimson. Hope this helps.

          • Re: Cannot install AMD Application
            tomtalk24

            How to perform a clean driver install This will remove the borken uninstall. This is likely the problem, I have had it where you go to uninstall, it says its done but isnt then fails on something when installing again. CCleaner wont remover everything and I dont like AMDs uninstaller.

            Give it a go, make sure you offline to stop Windows Updates, and it should work fine.

              • Re: Cannot install AMD Application
                drew_eh

                Hi TomTalk,

                Here are comments in regards to the link you provided "How to perform a clean driver install".  Remember the driver installs fine, just the application does not.  Anyways.

                 

                1) Windows update - updated, check, done.

                2) Disable anti-virus - Windows defender, check, done.

                3) .Net framework - updated, check, done.

                4) Downloaded driver to desktop, unpacked to C:\AMD folder as per default setting.  Done

                5) Deleted existing drivers - done, used amd cleanup utility, I'm now at some crazy low resolution. Done.

                6) Control panel - no references to "AMD" drivers or software exist.  Only the Catalyst Control center as I previously mentioned before in another post.

                6a) Rebooted to safe mode, ran regedit, searched for "AMD", "Catalyst", and "ATI" and I delete any reference that appeared to be for video purpose (yes I know AMD is common for processor technology and other chipset which is why the process took a very long time).  This also removed the "Catalyst Control" software from appearing in the "Add Remove Program" listing.  Rebooted into safe mode again.  I don't have intel, only AMD.  I ran the unpacked download in C:\AMD as I mentioned before, the application would not run in safe mode, it failed at the 'Analyzing System' stage, error said something similar to 'Cannot run auto-detect.  Contact AMD support', then the application closes.  Rebooted to normal mode.  Ran the setup file in C:\AMD, it runs fine, I uncheck all items except Install Manager (mandatory), and the AMD Gaming Evolved App, click Install.  At 0% a popup error appears as it always has as mentioned previously with the error "Application Install: install package failure!".  I've also tried running as administrator and another completely fresh new user so it is not a local profile issue too.

              • Re: Cannot install AMD Application
                ccana

                I'm having the same exact issue and get the same error with the 15.11.1 or 15.12

                 

                The clean driver install doesn't fix anything and the Application Install error pops up every time.

                 

                Has there been any update to this issue?

                  • Re: Cannot install AMD Application
                    drew_eh

                    I originally posted this question, no I do not have solution yet.  The above mentioned solutions did not help.  Perhaps because they weren't reading it properly, it is not a driver issue, but an application issue.  I cannot install or uninstall the app or whatever is causing the thing to fail.

                      • Re: Cannot install AMD Application
                        tomtalk24

                        The drivers are complementry to the application. You wont be able to install/uninstall the application alone, the "how to clean install driver" suggestion is most relevant in this situation as DDU will remove any obvious trace if both application and driver. Think of driver and application as a package, generally people will refer to the package as just the Driver. Think of DDU as a more advanced AMDCleanup. So read? thoroughly. Post back your findings or your thread will be regarded as dead, if it hasn't worked we (myself and others in the community) can offer more advice. Easy.

                         

                        Another suggestions is providing your registry is clear and as far as Windows is concerned anything AMD is deleted, you could try another directory to unpack and install the software and drivers, hopfully replacing whatevers is left from the broken install.

                        The only real last option is to refresh Windows 10. You should have an option just to clear out just the OS, not programs and documents.

                          • Re: Cannot install AMD Application
                            drew_eh

                            Hi TomTalk,

                            In regards to your comment about not being able to install the drivers and not the application, I beg to differ, otherwise I wouldn't be posting this issue.  The driver installs fine.  With the latest release nearest (or on) Jan 8, 2016 I did download the package to my desktop, running the program locally, when I click the "Browse" button to pick another folder makes the application crash.  If I just let the unpacking program use the default folder of C:\AMD... it works fine.  I never had this issue on any other version (or program for that matter).

                             

                            Thank you for the idea to refresh Windows, however, I'm not that desperate and think that would be an absolute last worse case scenario.

                        • Re: Cannot install AMD Application
                          tomtalk24

                          If the above method didn't remove the problem links/files or whatever, providing your just left now with a broken uninstall link in Program and Features, you can try installing a much older CCC Omega 14.12. Once installed you should be able to remove that driver (and application, if that needs explaining) and go ahead and install your driver of choice. Imagin this as replacing the missing uninstaller (in the eyes of Windows and AMD).