AnsweredAssumed Answered

HD 7990 problems

Question asked by thanightmare7 on Dec 16, 2015
Latest reply on Dec 17, 2015 by tomtalk24

So recently there was a sale at a hardware parts store in my village, and I came across a sealed XFX HD 7990. When I came home I immidiatly used the amd cleanup utility to clean the drivers from my previous card (r9 290) after a reboot I inserted my HD 7990 while the system was powered off. When turned on everything worked fine, so I used the amd auto detect utility to install the latest drivers. But when I tried to play some games they just didn't want to work..

 

Team fortress 2: I get 2-10 fps in the main menu which makes it impossible to adjust the settings.

Minecraft: Immidiatly crashes..

GTA V: Worked but it would give me a pink static screen effect.

Left4dead2: wouldn't even start....

Battlemage lichdom: Immidiatly crashed after loading the menu.

 

After all this I've reïnstalled the crimson drivers again, manually this team to the latest full version. I even disabled crossfire to see if that might be the problem but same results. But the weirdest thing of all is that a program like Heaven benchmark worked perfectly fine, I even had a stunning fps of 150 average...

 

I haven't gotten time to install the CD drivers since I don't have a CD-drive, but I don't want to use these... They're very old.

 

PC specs:

 

cpu: FX 9590 (runs at 5.2 ghz with 1.49 volts)

motherboard: asus crosshair v formula thunderbolt (not the Z version)

psu: Corsair ax 760

ram: 16 gb ddr3 2133mhz kingston hyperx predator

ssd: corsair force GT 240 gb

old gpu: club 3d r9 290

new gpu: xfx hd 7990

 

If anyone knows a solution please tell me.

Outcomes