2 Replies Latest reply on Dec 16, 2015 4:31 AM by calav3ra.de

    Screen corruption/flickering after resume from standby (s3)

    calav3ra.de

      Hi,

       

      since 15.11 (now also on beta driver) i have severe screen corruption on Win 10 with my AMD R9 290 4GB, never had that before.

      The screen flickers everytime a window is redrawn or the mouse is moved. It stops when nothing happens on the screen.

       

      This can be stopped altogether by toggling the VSR option, it doesnt matter in which state it is afterwards, it just stops after one toggle.

       

      I think the screen configuration is kind of messed up.

      I own a Dell 2560x1440p screen connected via a Displayport cable.

       

      This is really annoying, because i use the system standby mode a lot to save energy when leaving the computer, which i do quite often.

       

       

      Thanks for any help!

      Greetings

        • Re: Screen corruption/flickering after resume from standby (s3)
          amdmatt

          Does the issue occur on our Catalyst or Crimson drivers? If it's one or the other, please try updating/rolling back to see if that resolves the issue.

           

          Another cause could be the DisplayPort cable. What make and model cable is it? Is it a DisplayPort 1.2 certified cable? We recommend DP cables to be certified and no longer than 6.6 Feet or 3 metres long.

            • Re: Screen corruption/flickering after resume from standby (s3)
              calav3ra.de

              The crimson driver. I will check my DP cable and report back. Thanks!

               

              Edit: It's a 4 foot miniDP cable, and all it says is: "Displayport Cable E236508 EWM-Style Amphenol" where the latter seems to name the company.

              Doesn't look highquality, but the only different cable i own right now is 1.5 foot HDMI cable, i'd need to buy a new mDP cable then.

               

              Edit 2: I have a different issue with my monitor/cable/gpu i want to mention, it didn't bother me really but i need to turn on my monitor first before i turn on the PC because else it wont boot really. In this case i'd have to press the power button another two times to get it boot if the monitor was turned on too late. I found out about something related to a PIN21 being used to bring current to the monitor, and a solutino would be buying a cable that doesn't use this port.I find this really odd.

               

              Edit 3: Seems like my cable is a DmDP 1.1 cable. the company does have certified cables, but your article mentions power-up problems. DANK!

               

              I will buy an new cable and see how that goes!

               

              Any ideas? Thanks again!