4 Replies Latest reply on Mar 24, 2016 5:45 AM by amdcfx

    No Crossfire after Crimson update

    bugsdad

      I had a working system with crossfire enabled and then did the Crimson update. Now I have no crossfire at all. The Crimson software shows it "linked" but it is not functioning. When I run the "Overdrive" software, there is no evidence of having two video cards in crossfire mode at all. I have windows 7 64 bit service pak 1. Everything worked before the update. Clean uninstall, etc. I can give more specs but the cut to the chase is that there is no crossfire with the Crimson. What do I do?

        • Re: No Crossfire after Crimson update
          tomtalk24

          Reinstall Crimson using DDU again. It will show up.

          1 of 1 people found this helpful
          • Re: No Crossfire after Crimson update
            abi

            this worked for me, on the radeon settings, go to display. On Display go to the top right corner and seect additional settings,this will open a new window and there you will find amd crossfire were you can enable/disable option.

            1 of 1 people found this helpful
              • Re: No Crossfire after Crimson update
                bugsdad

                I got it fixed. After the initial install, I could click on "Display" but there were no "Additional settings". All it would do is show the type of monitor I had and I could not change anything. I had to uninstall everything with DDU. Disabled my antivirus. Installed an old Omega version of the CCC that I kept in a file that worked. Did a "minimal" installation and then chose the individual pieces, one at a time, starting with the new driver and ended with the Radeon Settings program. It worked great. Everything is available now and it all works. I have played with enabling both of my cards during some games and disabling one in others and I have full control of the cards now and all of the features. I am disappointed to report that when using the link that automatically finds the most appropriate driver for your system and all you have to do is click "install" does not work. It would either freeze at 2% or 11%. Something is definitely not right in those apps for win 7 pro with 64 bit.

                 

                 

                 

                      From: abi <amd-external@jiveon.com>

                To: George Blake <georgeblake4399@yahoo.com>

                Sent: Monday, December 28, 2015 2:56 PM

                Subject: No Crossfire after Crimson update | AMD Developer Forums

                    

                #yiv6082132777 * #yiv6082132777 a #yiv6082132777 body {font-family:Helvetica, Arial, sans-serif;}#yiv6082132777 #yiv6082132777 h1, #yiv6082132777 h2, #yiv6082132777 h3, #yiv6082132777 h4, #yiv6082132777 h5, #yiv6082132777 h6, #yiv6082132777 p, #yiv6082132777 hr {}#yiv6082132777 .yiv6082132777button td {}

                |

                 

                  Community 

                 

                 

                 

                 

                No Crossfire after Crimson update

                in AMD Crossfire, Dual Graphics & Switchable Graphics  this worked for me, on the radeon settings, go to display. On Display go to the top right corner and seect additional settings,this will open a new window and there you will find amd crossfire were you can enable/disable option. Reply to this message by replying to this email -or- go to the message on Community  SHARE THE LOVE! Help other developers by marking replies to your questions as Helpful or Correct. If you are the original question asker, you can mark replies as Helpful or Correct by:  

                   - Go to the message on Community (you’ll need to log in).

                   - Click on either the Helpful Answer button or the Correct Answer button.

                   - Pat yourself on the back! You’ve helped others who have the same question as you by telling them which replies are helpful and correct.

                  This email was sent by Community because you are a registered user.

                You may unsubscribe instantly from Community, or adjust email frequency in your email preferences

                 

                  |

              • Re: No Crossfire after Crimson update
                amdcfx

                I think that AMD have some problems with ALL Crimson drivers.

                I find that Catalyst/Crimson 16.3.1 isn't working at all with my HD7990, even if it says that it's 'linked'.

                'Stable' (because it isn't stable at all - it froze when booting, it lags on desktop, and refuse to reboot my computer until I restart it manually through button) 15.12 Crimsons work only first time after restart with CrossfireX - after it's working on 1 GPU.

                Install AMD Catalyst 15.7.1 - working no problem. Now if I want fixes, for cards, I think that I must copy DLLs manually or I have to install drivers on this driver. But I think it would result in complete instability of the system, because clean Crimsons have so much problems that I can't counter. At least they fixed the 144hz problem, to downclock the card - but still other things are completely messed up.

                All drivers have been cleaned manually through DDU and AMD Cleanup utility (amd drivers on 50% of unistallment have become just black screen - Crimsons are terrible, I can't understand, how they can't do even uninstall tool inside the driver without crashing computer)