5 Replies Latest reply on Dec 13, 2015 10:57 PM by bradman1313

    R9 280x screen flicker question

    bradman1313
      Hello, recently bought a Powercolor TurboDuo R9 280x (PowerColor TurboDuo Radeon R9 280X DirectX 11.2 AXR9 280X 3GBD5-T2DHV2E/OC 3GB 384-Bit GDDR5 PCI Express 3.0 HDCP Ready … ) to replace my 6850, even though it worked well with all my games except Fallout 4. It works great, except for a small screen flickering problem.
      This is my performance during a benchmark:
      Gyazo - 6ff7149dd8bd90d6e4437f9b904184bb.png
      Starting after installing my new card and the Radeon Crimson drivers (post fan-control problem), during 2D games (notably Starbound) and seperately while watching YouTube videos, my screen will flicker horizontal white and black lines for a VERY brief moment (maybe 1-2 hz) then return to normal. This happens erratically, between 1-10 minutes between flickers. The picture on the monitor seems to "shift" downward when this happens. The problem occurs in both fullscreen and windowed. It doesn't stutter or drop fps before or after. It doesn't happen while taxing the GPU in Furmark or Kombustor, or while playing much more intensive games. I have adequate power to run the GPU.
      Things I have tried:
      Reseating the GPU
      Installing the latest update of CCC instead
      Swapping DVI cables
      Underclocked to 950/1400 from 1030/1500
      Using RadeonPro to force clock speeds
      Nothing has changed.
      Should I RMA the card? Will it get worse down the road? I've tried googling but screen flickering is a pretty common problem. Thanks for looking.
        • Re: R9 280x screen flicker question
          amdmatt

          It sounds like it could be a driver issue, please provide a report and screenshots here.

           

          If the issue does not occur on older drivers, such as Catalyst 15.11.1 Beta or Catalyst 15.7.1 then i doubt the graphics card is faulty.

          • Re: R9 280x screen flicker question
            techsmurf

            EDIT: This may not help you. I just noticed you'd already forced the clocks without a positive result.

             

            ---------------------------------------------------------

             

            This sounds like what is referred to the "screen tearing" issue with underclocked 280x cards.

             

            With catalyst drivers, enable Overdrive and create a new "profile" and edit its XML file at C:\Users\USER\AppData\Local\ATI\ACE\Profiles\*.xml

             

            Find: <Feature name="CoreClockTarget

            Change next line: <Property name="Want_0" value="30000" /> to <Property name="Want_0" value="50100" />

             

            Find: <Feature name="MemoryClockTarget

            Change next line: <Property name="Want_0" value="15000" /> to <Property name="Want_0" value="30000" />

             

            This will increase the minimum GPU/MEM clocks. These are the actual values used in my smurfy.xml profile, and have made my 280x go from crashing within 5 minutes of starting a youtube video to rock-solid stable. The actual reported clocks from Afterburner do not match quite what I put in the XML (seeing 501/700), but since it's rock solid stable I don't much care to tweak further to force that 300MHz memory clock.

             

            Unfortunately you will be stuck with Catalyst, as Crimson's AMD Settings does not offer this functionality at this time and no solution has been reached. You can run the new drivers with Catalyst by just installing the minimal driver on top of your Catalyst installation.