AnsweredAssumed Answered

How to force PCIE 3.0

Question asked by justme on Dec 5, 2015
Latest reply on Dec 6, 2015 by john007

I have the following setup relevant to this topic/question:

 

Asus A88XM-Plus MB

AMD A8-7600 APU

MSI R9 280x with 3GB DDR5

 

So all the boxes are ticked to have PCIE 3.0. Using various programmes including TechPowerUp GPU-Z, which all state that whilst PCIE 3.0 is supported, it is all running at PCIE 2.0 (even when under full load).

 

I have updated the Bios, which is already currently up to date.

I have checked the Bios, but there is no way to enable/control the PCI buses at all from the bios.

Nvidia has a Force Gen3 programme, but I will not try it on my AMD setup.

I created an entry in my Windows 10 64bit registry, which was supposed to enable/force PCIE 3.0, but all it did was drop to PCIE 1.1 on idle, and rise to PCIE 2.0 under testing.

The power profile in windows is set to Performance, and I have OC'd the Memory, the APU and the GC all within manufacturers tolerances, still no change.

I have double checked the specs on the MB, GC and APU with manufacturers websites, all state PCIE 3.0.

I have the GC in the correct PCIE slot.

The Asus website states that PCIE 3.0 can only be enabled by using a FM2+ APU/CPU, which the A8-7600 is.

 

I have read quite a bit on the debates between PCIE 3.0 and PCIE 2.0, which are marginal at best, but I created this system from scratch to be fully PCIE 3.0 compliant, yet it doesn't work.

 

Anyone have any suggestions?

Outcomes