AnsweredAssumed Answered

R9 280 - Crimson Drivers Failing to Install

Question asked by lloydski on Dec 5, 2015
Latest reply on Dec 5, 2015 by lloydski

Hi,

 

I have been trying to update the drivers for my R9 280. Initially I used the autodetect method and everything went smoothly until the end where it just said that the drivers and software had not been installed, despite going through about 5 minutes of installing.

 

After this I decided to try and uninstall and try again. Same result. My next try involved using the cleanup utility and then downloading the full driver directly from the website. Exactly the same thing happened, bu this time the "gaming evolved" app had definitely been installed, and "Radeon Settings" was running but said there was no installed amd device whenever I tried to open it. Apparently there was a warning during install, and I have attached the log to this post in the hopes that someone will be able to tell me why on earth this is happening.

 

For now, I have reverted back to the catalyst drivers that I was using before.

 

Thanks in advance for any help.

 

Specs (Currently listed from Speccy so my 280 isn't listed due to no drivers):

  Operating System

  Windows 7 Home Premium 64-bit SP1

  CPU

  AMD Phenom II X6 1090T

  Thuban 45nm Technology

  RAM

  8.00GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)

  Motherboard

  FOXCONN A88GMX (SOCKET AM3) 40 °C

  Graphics

  2369M (1920x1080@1Hz)

  ATI Standard VGA Graphics Adapter (Foxconn)

  16MB ATI Standard VGA Graphics Adapter (MSI)

  CrossFire Disabled

  Storage

  931GB Hitachi HDS721010CLA332 ATA Device (SATA) 32 °C

  931GB Western Digital WD My Passport 07A8 USB Device (USB (SATA)) 34 °C

  Optical Drives

  MagicISO Virtual DVD-ROM0000

  WD Virtual CD 07A8 USB Device

  Audio

  SB Audigy

 

Edited to add in computer specs.

Attachments

Outcomes