AnsweredAssumed Answered

Dead Space 3 misses numerous visual effects on R9 290

Question asked by kifa on Nov 30, 2015

So I've bought Dead Space 3 on a recent sale, in hopes of finally completing the trilogy, and I've noticed a "funny" thing about the game - it does not render many of the visual effects despite they are enabled in menus. Namely - SSAO, DoF and partially bloom/glow do not render at all. They are computed though, because framerate is slightly and consistently reduced when they are enabled in the options menu. I've tried many things - resetting app profile, deleting it altogether, different settings, even renaming the exe to confuse the drivers and injecting SweetFX - all to no avail. Other than those the game runs fine and does not show any problems, but I've tested it on my laptop with nVidia GPU and there everything works as it should.

 

My specs:

AMD Phenom II X6 1100T (not overclocked)
16GB DDR3-1333 RAM
ASUS M5A99X EVO R2.0 motherboard
ASUS Radeon R9 290 (not overclocked)
Windows 10 64bit
AMD Software Crimson

 

I've reported the issue already and while I don't consider it all that big, I'm curious to know if anyone here experienced something similar at any point and if someone happens to have a workaround/fix?

 

UPDATE: I've managed to do a comparison screenshot for the issues I'm having. One screenshot is made with GTX 650Ti I've borrowed and stuck in my system, and the other is from my regular R9 290. Both are at 1080p and identical settings. You clearly can see that SSAO and reflections don't render at all on AMD hardware.

Outcomes