2 Replies Latest reply on Dec 10, 2015 10:12 PM by lukdz

    Can't open AMD Radeon Settings

    lukdz

      Hi!

       

      I updated my software yesterday and now the usual Catalyst Control Center doesn't show up, seems to have been replaced by AMD Radeon Settings, which i can't open because it crashes. My graphics card is an AMD Radeon R7 200 series. Sorry if my english is not easy to understand, it's not my first lenguage.

        • Re: Can't open AMD Radeon Settings
          amdmatt

          Sorry to hear you've been having problems. Please uninstall the Crimson drivers, then download and run the AMD Clean Uninstall Utility. I would then advise download the last stable Catalyst drivers for your system, available here.

           

          Please report the issue you had with our Crimson drivers here.

            • Re: Can't open AMD Radeon Settings
              lukdz

              Thank you for your answer. Shortly after I asked this I realized I had a folder which contained all the installers of previous versions, so I installed the last Catalyst drivers that were in that folder and could, once again, use the graphics card software (which I use to change the settings of my monitor).
              Today I did as you told me and ran AMD Clean Uninstall Utility, this erased all the drivers and also the installers on the said folder, so I couldn't install the Catalyst drivers again from there. I tried to download them from the link you attached, but I can only find Crimson drivers. So I downloaded what I could because as all the drivers were erased, everything got kind of messy. Now I'm back at the start but not knowing where to find the Catalyst drivers.

               

              EDIT: updating my OS solved the problem, I can now open the AMD Radeon Settings. But I still have an issue trying to change the settings of my monitor, when I updated the drivers I was working, and I had lowered its brightness and contrast levels, now I can't get them back up, and changing the settings from AMD Radeon Settings does nothing.