21 Replies Latest reply on Apr 6, 2016 4:59 PM by jackwraith

    Cannot install AMD drivers through catalyst install manager or the new AMD install manager?(Windows 10)

    keatonomore

      I have been trying to fix this without the forums help for about four hours and i am at a complete and total loss. So here's the story.

       

      What happened: I had noticed that my display driver was listing my Video card as an Hd 7900 after updating to windows 10. It's an R9 280, so this would make sense as they're just re-branded 7900's. However,I knew that I would generally benefit from having an up to date driver. So, I went into device manager to try and see if i could just have windows do it rather than having to go to AMD's website (The website is a bit convoluted for me so I try to avoid it). I got the issue wherein it finds the driver but fails to install it. No big deal, I suppose i'll just have to manually install it from the website, as much as i didn't want to. Here's where it gets interesting. I uninstalled all the old drivers and attempted to install the new one. Immediately after reaching "Display Driver Install", the AMD Install Manager gave me a "AMD Install Manager Has Stopped Working" Error. I did some research online and found a few possible solutions.

       

      What I've Tried:

      1. Installing with the disk my graphics card came with. The Catalyst Install manager completed, however it gave me an error log wherein it states that the driver failed to install. I've attached it, in case its any help.
      2. Booted to safe mode, ran UDD, restarted, and tried again using both the website and the install disk that came with my card. Nada.
      3. Disabled forced signatures on drivers under startup settings.
      4. Manually deleting every single AMD/ATI program file I could find, restarting, and trying again using both methods. Neither worked.
      5. Searching online for other possible solutions. Now stumped.

      So now I'm at a loss and i would appreciate any help you can offer. Thanks, all!