2 Replies Latest reply on Nov 30, 2015 11:23 PM by seifer

    new crimson driver issues

    seifer

      Hi,

       

      System

      FX 8350

      Asus Crosshair V Formula-Z

      Asus r9 270X (x2) crossfire

      RAM 16 GB @ 1866

      Windows 10 64 bit

       

      Issues

      I just installed the latest drivers from AMD website and crossfire works fine but not on all games. For some reason every time I check  the box "Enable AMD Crossfire for DirectX 9/10/11 that have no associated application profile" the box doesn't stay checked. Because of this I cant run games on AFR at all. Games like Rust and such that don't have an AMD profile wont run on crossfire. Other issue is with planetside 2, games crashes on loading screen if crossfire is enabled. I did notice others are having the same issue with directX 9 games like starcraft 2 and diablo 3.

       

      I used DDU in safe mode to clean all the previous driver files before installing the latest one. Any help on this matter would be great. Thanks.

        • Re: new crimson driver issues
          amdmatt

          Please leave global settings at default. Add the game executable file (i used Fifa 16 in my examples below) to Radeon Settings.

           

          1.jpg

           

          Please make sure CrossFire mode is set to AFR Friendly. By default it will be set to disabled.

           

          2.jpg

           

          Please launch the game using Radeon Settings.

           

          3.jpg

           

          You can report the issue with Planetside 2 here.

           

          Was my post helpful? If it was, please make sure to mark it as correct/helpful in order to assist others.

            • Re: new crimson driver issues
              seifer

              Hi Matt, thanks for the reply. I already try this. With planetside 2 I cant launch the game from radeon settings for some reason. I tried AFR profile on planetside 2 and also the AMD profile for the game since it has one but still crashes on launch. I went a step further and installed smite and it does the same thing.It doesn't matter what settings I use while crossfire is enable both games crashes on launch. I uninstalled the drivers, used ddu in safe mode and installed the crimson drivers again but still the same issue with both games. Funny thing is that only happens with directx 9 games. Battlefield 4, hardline, titanfall and others games work just fine with crossfire. I already reported the issue to amd. Once again thanks for your help Matt.