5 Replies Latest reply on Nov 27, 2015 11:12 PM by tannah

    USB 3.0 no longer working after AMD crimson update

    danb5298

      Basically as title states. I know that driver installation was included in the new AMD update, but now none of my 3.0 ports are connecting to any device.  I am running Win10, r9 270x, and gigabyte 78-lmt mobo. Any help would be greatly appreciated.

        • Re: USB 3.0 no longer working after AMD crimson update
          tannah

          Is that a AMD Motherboard?

          If so I had a similar problem with my Asus Sabertooth 990FX. I uninstalled the Crimson Driver and reinstalled due to a different problem. On reinstall of the Crimson Driver I noted that the driver did not detect the AHCI or USB drivers on my motherboard. I installed amd-catalyst-15.7-sb-sata-ahci-win10-win8.1-win7 South Bridge drivers It detected the missing drivers, and it solved my problem with the USB.

           

          Out of curiosity I re-ran the Crimson drivers afterwards and tried a in place update and it said all the drivers are current.

          If you have a AMD motherboard, give it a shot and see if it works for you.

          1 of 1 people found this helpful