5 Replies Latest reply on Jan 31, 2016 3:21 AM by fisk

    Crimson Global Overdrive broken

    specialsymbol

      Hello, I don't know how to file a bug report.


      I got the latest Crimson driver 11.15 and the Global Overdrive settings are broken.

       

      In particular the speed setting for the memory is bugged. I can set the memory speed to something lower than the 1500 MHz, but it will be stuck at the new setting - the setting is not the maximum allowance (as it was in the last driver), but it's fixed at that speed.

       

      Of course, this leads to higher temperatures.

       

      Also, once you initially set a value for memory speed you can't go below that later on. So I first set 1250 MHz, then it was stuck there.
      I thought maybe there's a load glitch or something, so I set a new value of 1325 MHz. Now I can't go back to 1250 MHz, even after closing and restarting the control center.


      Also the temperature of the card is now stable at a moderately high value (39°C) and the core clock doesn't fall anymore below 500MHz, probably due to the memory clock being fixed.

       

      My graphics card is a Radeon HD 7970, the mainboard Gigabyte with Z77 chipset.

        • Re: Crimson Global Overdrive broken
          walterpeck

          I also experience this issue, exactly as described. 7970 on an Asus P7P55D-E Pro

          2 of 2 people found this helpful
          • Re: Crimson Global Overdrive broken
            xenthos91

            Can confirm - using the crimson drivers with my 7950 the overclocking feature is broken. The core clock shows up as 1100 however GPU-z and other monitoring software shows stock clocks. As for the memory overclock - once applied it is stuck at 1400Mhz even if I reset the global setting. This is dangerous too because this bug actually locks down my GPU voltage at 1.25v all the time!

             

            AMD fix this please...

            • Re: Crimson Global Overdrive broken
              julien.behem@lanproject.net

              I also have this issue with new Crimson driver 15.11.1 : I can't set a memory speed lower than 1450 (default is 1200Mhz).

               

              Go into Games / Global parameters / Global overdrive

              Increase memory speed up to 1450Mhz and apply.

              Then try to decrease the value : impossible ! the lower setting is 1450 and you can't go below.

              Also tried to reset to default values with the up-right button : speed is indeed set to 1200 but the cursor is still at 1450 !

              I suppose you may get the same behavior with different values depending of your card (mine is a Sapphire Radeon 7950 Vapor-X).

               

              The only way I found to change the value was to use Sapphire Trixx tool instead of the new Crimson tool.

              • Re: Crimson Global Overdrive broken
                walterpeck

                This still hasn't been fixed in 15.12. I even removed them which returning my memory clock speed to normal but the issue returns once global overdrive is used again.

                • Re: Crimson Global Overdrive broken
                  fisk

                  Okay, it's clearly Crimson UI bug, and currently there is no easy way to fix it. But there is still a solution (but after it you can't overclock your card through Overdrive - till official fix will be released).

                   

                  Here is the only fix for now (tested):

                   

                  1) Do a clean uninstall of your Crimson with DDU in safe mode

                  2) Reboot

                  3) Install newest driver package again

                  4) Don't touch Overdrive feature.

                   

                  After it you can run HWMonitor (or something similar) to finally see your card is working on 2d clocks again (woohoo!), and 3d clocks is set to default too. If you still need to overclock your hardware, use MSI Afterburner (work for me, and isn't bugged).

                   

                  Sorry for my English, just want to help you all