AnsweredAssumed Answered

Fury X sudden black screen and no output?

Question asked by galivice on Nov 25, 2015
Latest reply on Jan 8, 2016 by electricessence

I just got a new Gigabyte Fury X and I have been having some issues.

 

Every once in a while, my screen will go black and my monitor will say that it isn't receiving any input.  (Not sure if it helps, but when this happens, the fans seem to suddenly go to maximum speed for a second.)

 

Nothing happens if I turn the monitor on and off, or unplug the cable and plug it back in again.

 

This doesn't cause my computer to turn off - I have to turn it off myself by holding the power button.  When I turn my computer back on, I don't see the "Windows had an error" message that you might normally see with crashes.

 

(Though the computer doesn't power off, it stops working - sound cuts out about a second after the screen goes black, and nothing else on my computer keeps working, ex. instant messaging and logging programs).

 

I do not encounter this problem only when I am playing games (mainly Fallout 4 and Dota 2) - I also have this happen when I am just browsing the internet.

 

This first happened when I was on Windows 8, but I have recently upgraded to Windows 8.1 in the hopes that it would fix this problem.  It did not fix it, though it does seem to happen less frequently (maybe?).

 

I have uninstalled my old drivers and tried both the "stable" and beta drivers.

 

I have tried using an HDMI cable and 2 different DisplayPort cables (one normal one that I bought, and one mini-DP cable that was included with my monitor).  I also tried using different power connectors.  I am only using one monitor.

 

Temperature logging with GPU-Z shows my max temperature at 51 celsius while gaming (though it logged two entries of 0 celsius right after the blackscreen, before it stopped working).  CPU temperatures are also low.

 

ASUS MG279Q (FreeSync disabled) @ 1440p 144hz

 

i5-2500k (not overclocked)

ASUS P8P67 PRO

16GB RAM

Intel 730 Series 480GB SSD (plus a couple other drives for storage)

Corsair TX750W

 

I have been using this setup (with a 7970 instead of the Fury X) with absolutely no problems for a long time.

 

Does anyone have any ideas?  I am hoping that I don't have to RMA my card - I pre-ordered one but I had to return it because it had the bad pump...but then it took me 4 and a half months to get a replacement!  I don't want to wait another 4 months!

Outcomes