9 Replies Latest reply on Jan 2, 2016 11:52 AM by sobellge

    Crimson drivers will not install (any more)

    luckypunk

      Hey, I have a problem with Crimson that I haven't seen anyone else have so far - wondering if i can get any advice.

       

      I went to install the new crimson drivers/software yesterday. First time they installed fine (clean install), then I (perhaps stupidly) wanted to compare to the previous 15.11.1 beta drivers, so I uninstalled (using AMD Cleanup utility) and reverted to 15.11.1, still fine. Then I wanted to go back to the crimson drivers to leave them on and give them a longer test. This time I used the AMD minimal setup, thinking this perhaps just installed the crimson driver and not the whole software package. When I realised it was just going to download the same things (and I have a slow internet connection), I cancelled that install, intending to just use the full package installer I already had.

       

      It seems it didn't like being cancelled though, cos now I can't install the Crimson driver. It will install the rest of the new package, the GUI etc, but fails on installing the driver. You just get a window at the end of the install saying 'the drivers were not installed, check log'. When I check the log it isn't much help, just says 'AMD driver failed to install'.

       

      I can, however, still install the old 15.11.1 catalyst driver.

       

      I've tried many times to reinstall Crimson, using either DDU, or AMD cleanup utility to do a clean install but it just won't. I can't do a system restore (didn't realise you need to enable it on Win 10...). I'm now a bit worried that unless I fix this, it will never install newer crimson drivers.

       

      My system:

      Asus r9 290

      i5 2500k

      Gigabyte p67a-ud3-b3 MB

      Samsung SSD/WD Black HDD

       

      Any advice greatly appreciated!

        • Re: Crimson drivers will not install (any more)
          luckypunk

          Update: This may not be any help to anyone but...haven't been able to get any advice, or find a fix or even a direction to go in for this, so tried some things. Tried various combinations of removing all drivers with AMD clean uninstall, the Crimson uninstaller and DDU, sometimes using all or just one. Also tried AMD chipset drivers (this just installs an old driver from earlier this year). No effect, still installed to 56% then got an error message saying drivers were not installed - no further clue as to what happened.

           

          Tried a disk repair, then tried a reg cleanup - this at least had some effect. Unfortunately it made things a little worse. Now Crimson only installs to 2% then goes straight to the dialogue box saying drivers were not installed - sounds like a problem lots of people are having. Anyway, something in the registry maybe...?

           

          Just going to go back to 15.11.1 and hope the next Crimson goes in ok...when is that going to be...

            • Re: Crimson drivers will not install (any more)
              ray_m

              Try disabling your internet connection and then installing the driver.

                • Re: Crimson drivers will not install (any more)
                  luckypunk

                  Hi, appreciate the tip, but didn't work I'm afraid.

                   

                  Clean installed (uninstalled with AMD clean and DDU), internet adaptor off, antivirus off - same as before, 2% then straight to the 'fail' dialogue box.

                  • Re: Crimson drivers will not install (any more)
                    archerr

                    Same problem but i noticed that the windows didnt support the 15.300 driver, Windows 10 pro updated to last version did it have support from you guys?

                      • Re: Crimson drivers will not install (any more)
                        luckypunk

                        Ok, gave up for now and settled for 15.11.1 beta drivers...or so I thought.

                         

                        Just got Elite: Dangerous and discovered the problem with AMD drivers and supercruise mode. Not that Crimson apparently fixes this issue anyway, so seems it has just been forgotten about? So now apparently I have to revert to 15.7 drivers intended for Win7 - what's worse is AMD don't even provide download links for old drivers, not that I can find anyway: everything redirects you to the new download page for Crimson or 15.11.1 beta - all very well if Crimson worked and fixed the Elite issues but as it doesn't, why no old version drivers to download?

                         

                        Doesn't seem like good service from AMD. I'm fairly new to PC gaming (although not to PCs in general - I've always used nvidia cards previously) and to be honest I'm kind of regretting buying AMD, as it seems like a lot of effort to get things working and there isn't a lot of info from AMD themselves. Most information on fixes has to be gleaned from forums and the like.

                         

                        Anyone any news on some Elite fix drivers?

                          • Re: Crimson drivers will not install (any more)
                            luckypunk

                            Hello,

                             

                            Just in case it's of any use to anyone, I tried the latest beta driver (still called 15.11.1 but with a Crimson moniker) released on Monday, and it works! I know these were intended to fix the fan issue but they install for me whereas the previous ones didn't. Did a clean install, DDU to remove previous drivers, and it goes on fine now.

                             

                            Shame I have to revert to old drivers for Elite: Dangerous now anyway...

                    • Re: Crimson drivers will not install (any more)
                      vepalee

                      Try disabling antivirus and installing from setup.exe inside C://AMD/bin64. Worked for me.

                        • Re: Crimson drivers will not install (any more)
                          sobellge

                          I have been having the same issues. Every time I go to install the drivers, it only installs and HDMI audio driver, and AMD Install Manager, and AMD Gaming Evolved App.

                          I cant get any sort of Radeon Settings or CCC type program to install anymore. I have tried everything listed above.

                           

                          any help is appreciated

                           

                          Thanks