AnsweredAssumed Answered

BenQ XL2730Z unable to set 144hz Refresh Rate

Question asked by gh0st47 on Nov 25, 2015
Latest reply on Dec 19, 2015 by gh0st47

As title said, on the first day when I used the monitor I recall correctly Im able to run it at 2560X1440 @ 144hz Refresh Rate.
But now all sudden, I can only set it to maximum of 100hz ! I even checked it in games on the Settings my Refresh Rate I can only set it up to 100hz that's it !
I've tried every possible solutions.

 

1) Updated Drivers from 15.7 to Crimson, didn't work. ( Clean Install, used DDU etc )
2) Tried using DVI-D Dual Link that came with the monitor, didn't work, Crimson show monitor capable of 120hz but it's worst I can only set it up to 60hz max.
3) Disable FreeSync, didn't work. ( Also FreeSync is displaying the range of FPS 40 - 100 ) 
4) Unplugging and re-plugging back cables, didn't work
5) Found this weird solution online, some guy had same problem, he unplugged the power cord from the monitor and left it over night and it work for him
6) Another person on this forum had same problem, he too can't set it over 100hz, but after trying on his friend PC and so it went back normal for him....


I am literally out of ideas....I doubt it's a cable problem, I couldn't be so bad luck till the point both brand new cables is faulty could I ?? I didn't even use the DVI-D Dual Link before.
Some have asked me to use Custom Resolution, I wouldn't want to if possible, since I don't feel comfortable somehow forcing it. I mean it never has such a requirement to get a 144hz monitor to work to begin with. It's like example OCing, it is something I won't like to do.


Im using a Sapphire 290X Vapor-X and Windows 7 64-Bit, hope someone have a solution, Thank You.

Outcomes