AnsweredAssumed Answered

Crimson won't install

Question asked by brixx on Nov 24, 2015
Latest reply on Dec 29, 2015 by tomtalk24

Hi!

 

I just tried installing the new Crimson Software.

 

Before that, I got rid of my "old" 15.11 driver via "Display Driver Uninstaller".

 

But it just won't install. The files are unzipped and copied correctly, i.e. the unzipped files are where they are supposed to be.

 

But when I try to install the software, with Admin rights of course, it just says "Installing" for a split second and displays a "Installation succesfull"-message.

 

Of course I was suspicious, as I don't think that an installation that quick was plausible. So I checked the folder it should have installed to. But it's empty.

 

I also tried to uninstall it again via DDU, but there is no driver installed aside Generic MS VGA drivers. I then triede uninstalling possible Crimson files via

the Crimson installer. But while the Crimson installer tells me that I have installed the most recent software, when clicking on "Uninstall" it states that

there are no components installed at all.

 

So I had to go back to 15.11.

 

What am I doing wrong?

 

My specs: Windows 8.1 Pro with latest updates except some minor unrelated optional updates.

 

CPU: Xeon 1231v3

RAM: 4x4GB Corsair Vegeance LP DDR3 1600Mhz CL9

Board: MSI H97 Guard Pro

GPU: Asus Strix R9 390

PSU: be quiet! Dark Power Pro 11 850W

SSD: Samsung 840 Evo

Outcomes