0 Replies Latest reply on Nov 21, 2015 4:35 PM by exsorsium@hotmail.com

    Catalyst 15.11.1 Resolution Switching issues

    exsorsium@hotmail.com

      Hi all, I recently purchased and installed a Sapphire Nitro Radeon R9 390. I updated my drivers to the latest stable (15.7.1) and enjoyed my new card for a bit.

      Then I tried to play Fallout 4 and was disappointed with the performance. I heard from a friend that the beta drivers (15.11.1) promised better performance, so I uninstalled the stable drivers and installed the beta drivers. Turns out he was right and I get much better performance, yay!

       

      But that's not why I'm here. I'm having two issues since updating to these drivers, and I wanted to know if these are common and/or solved issues, or if they're in line to be fixed before being promoted to 'stable'.

      • Browsing the web with Google Chrome, I find if I scroll down the page too quickly on long pages (forums, reddit posts) I sometimes trigger a Display driver crash - the screen freezes, the mouse freezes shortly afterwards, then everything goes black for a bit, then it comes back to normal with a message from windows saying something along the lines of 'The display driver has stopped and successfully recovered'.
      • Launching most games gives me an interesting issue. So far, Fallout 4, Minecraft, Elite: Dangerous, and the Overwatch beta have done it to me. Upon launching, the display goes black, does a quick flicker to a black screen with the mouse cursor, then back to black screen, then another quick flicker with the black screen + mouse cursor. Then it shows the game screen as normal.
        • Weird Thing #1: Sometimes the Black-Flicker-Black-Flicker repeats another time before getting to the game screen.
        • Weird Thing #2: This happens if I alt-tab out of a fullscreen app, but I can alt-tab out of a Borderless window just fine.
        • Weird Thing #3: I have screen saver disabled and instead just allow my monitor to turn off after 10m. If I come back and wiggle the mouse to turn the monitor back on, it goes through the Black-Flicker-Black-Flicker-Screen again.

       

      So, known issue? Possible fixes? Or just wait till the developers release the next version of the driver and deal with it?

       

       

      For reference, here's some system specs. If you need anything else, I can try to provide.

       

      Graphics Card
      Sapphire Nitro Radeon R9 390 - stock settings

      Operating System
      Windows 7 x64 - 1920x1080

      CPU Details
      AMD 8-Core FX-8120 - stock settings

      Display Device(s) and Connection(s) Used
      Monitor: HP 2311xi - HDMI

      Motherboard or System Make & Model
      ECS A990FXM-A Deluxe 1.0

      System Memory Type & Amount
      16gb - Corsair XMS3 8GB (2 x 4GB) 240-Pin DDR3 1600 SDRAM

      Power Supply

      Corsair RM650 R