0 Replies Latest reply on Nov 21, 2015 11:40 AM by faar

    GPU Compute causing crashes when running with graphics tasks: R9 290X, 390X.

    faar

      Running Folding@Home in the background while doing other stuff - gaming for example - causes either driver reset or black screen and unresponsive system, or bluescreen with various Catalyst driver-related fault codes, usually within minutes but sometimes within seconds of starting the game application.

       

      You might say, "well, stop gaming while you're folding then!" - sure. (Semi)-valid* feedback! Problem is, it can happen just by browsing the web as well. Google Maps for example have caused this for me. The iCloud.com login screen caused the same thing (because of the full-window realtime blur effect I assume), in less time than it took for me to type in my email address and password! More and more websites these days use complex graphics, realtime 3D and whatnot, and you would not necessarily know what is about to happen before hitting a site. A random banner add on any site might be drawing complex graphics using GPU acceleration, thus potentially causing the PC to crash, and the user losing valuable data and risking file system errors and such.

       

      *IMO, under no circumstance should my PCs crash completely just for running two pieces of what is completely normal software together. That is not acceptable. I should be able to do more than one thing at a time with as complex and powerful an instrument as PCs are!

       

      This has occurred multiple times in a repeatable manner for me on two completely different PC systems:

      ASUS Rampage II Gene mobo

      Intel i7-920 CPU

      ASUS R9 390X DirectCU II 8GB GPU

       

      ASUS Maximus VI Gene

      Intel i7-4770K CPU

      ASUS R9 290X DirectCU II 4GB GPU

       

      It's worth noting that when I bought the 290X around february of last year, the then-current WHQL driver worked fine with running compute jobs together with gaming. However, I obviously can't go back to the november 2013 WHQL Catalyst release today, not least because I'm running Win10 now and I'm pretty sure it wouldn't even install properly if I tried... This issue didn't rear its ugly head until sometime in the spring, or maybe early summer of 2014, with the driver that was issued at that time, I don't quite recall anymore. Anyway, this flaw has persisted ever since, and it's truly annoying every time it happens, and it's still happening on the "new" R9 390X as well! Which is even less impressive I might add.

       

      No idea how to raise this issue with AMD driver quality assurance staff, so I post this here. Thank you for any assistance on this matter!